pycuda erreor

Im returning to CUDA after a 4 year hiatus. I have windows 7 enterprise on an Intel i&-2760QM with a NVIDA Quadro 1000M. I have sucessfully installed CUDA 6.5 and deviceQuery shows pass. In addition, I have installed Anaconda python 2.7 and it works for CPU type code. I have installed pyCuda-2014.1. But whenever I execute any pycuda routines (such as import pycuda.autoinit) I recieve a kernel error and a windows error dialog “python.exe has stopped working”

And Im wondring what Im doing wrong

“I have installed pyCUDA-2014.1” Perhaps you should define specifically what you did to install it. Are you following any particular set of instructions, such as:

http://wiki.tiker.net/PyCuda/Installation/Windows

or

http://blog.e13k.eu.org/2013/12/installing-pycuda-theano-and-anacoda-on.html#!/2013/12/installing-pycuda-theano-and-anacoda-on.html

?

Hi, I’m seeing the same problem as Pat:
when I try to execute a python file through the commandline containing
import pycuda.autoinit
(which in turn performs pycuda.driver.init())
python stops working and no error is shown.

I installed Cuda v8.0
following http://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html
and using Microsoft Visual Studio 2015 to compile some samples and the devicequery.
The installation seems to have worked, the devicequery says it found
the device Geforce GT 540M with cuda capability 2.1
Cuda driver version / Runtime version 9.0 / 8.0
Cuda driver = Cudart
Result = PASS
The samples worked fine.

Then pycuda 2017.1 using pip for python 2.7

When the error occurred, I tried some other things as well,
Installed boost library
Reinstalled pycuda following a combination of the instructions on
https://wiki.tiker.net/PyCuda/Installation/Windows
and
https://kerpanic.wordpress.com/2015/09/28/pycuda-windows-installation-offline/
My siteconf.py file looks like this now:

BOOST_INC_DIR = ['C:/boost']
BOOST_LIB_DIR = ['C:/boost/lib']
BOOST_COMPILER = 'msvc'
USE_SHIPPED_BOOST = True
BOOST_PYTHON_LIBNAME = ['boost_python-vc141-mt-1_65_1']
BOOST_THREAD_LIBNAME = ['boost_thread-vc141-mt-1_65_1']
CUDA_TRACE = False
CUDA_ROOT = 'C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v8.0'
CUDA_ENABLE_GL = False
CUDA_ENABLE_CURAND = True
CUDADRV_LIB_DIR = ['${CUDA_ROOT}/lib', '${CUDA_ROOT}/lib/x64', '${CUDA_ROOT}/lib/stubs', '${CUDA_ROOT}/lib/x64/stubs']
CUDADRV_LIBNAME = ['cuda']
CUDART_LIB_DIR = ['${CUDA_ROOT}/lib', '${CUDA_ROOT}/lib/x64', '${CUDA_ROOT}/lib/stubs', '${CUDA_ROOT}/lib/x64/stubs']
CUDART_LIBNAME = ['cudart']
CURAND_LIB_DIR = ['${CUDA_ROOT}/lib', '${CUDA_ROOT}/lib/x64', '${CUDA_ROOT}/lib/stubs', '${CUDA_ROOT}/lib/x64/stubs']
CURAND_LIBNAME = ['curand']
CXXFLAGS = ['/EHsc']
LDFLAGS = ['/FORCE']

I updated my GPU driver as well, from version 376.51 to 385.41.
I’m still having the same problem.

The OS is Windows 10 (came from 7), 64 bit

I managed to solve this problem by downloading pycuda with a wheel file from
http://www.lfd.uci.edu/~gohlke/pythonlibs/#pycuda
instead of a tar file from another site. Before installing, I upgraded pip and numpy.