Python 3.7 EOL

Python 3.7 is reaching end of life in about a month, most big libraries have already dropped support a while ago, yet Isaac Sim still ships exclusively with/for 3.7. Can we expect a timely upgrade to a newer Python version? Also, what prevents you from supporting a range of Python versions in the first place? I really like using your simulator, but I can’t hold development of our packages back just to remain compatible with Isaac Sim. Everyone else already supports 3.11 by now, 3.12 is around the corner…

Hello @philipbecker - The upcoming Isaac Sim release around July/Aug timeframe will be based on Python 3.10.

2 Likes