Python code execution error in Jetson Xavier NX terminal window

When I run python3 xx.py in the Jetson Xavier NX terminal window, the following error occurs

Error generated. /dvs/git/dirty/git-master_linux/multimedia/nvgstreamer/gst-nvarguscamera/gstnvarguscamerasrc.cpp, execute:740 No cameras available
[ WARN:0] global /home/txgt/opencv/opencv-4.5.2/modules/videoio/src/cap_gstreamer.cpp (1081) open OpenCV | GStreamer warning: Cannot query video position: status=0, value=-1, duration=-1

Hi,
The error indicates there’s no Bayer camera is connected. We support RPi camera v2 on Xavier NX developer kit. You may get the camera, connect to developer kit and try again.

The same error occurs even when I switch to and run it with a Raspberry Pi Camera v2. However, when I run IDLE, load the file, and press F5, it works. What could be the problem?

Hi,
If you use a clean system, Xavier NX developer kit + Raspberry Pi Camera v2 should work by default. Please try

  1. Re-flash developer kit to 5.1.2 or 4.6.4 through SDKManager
  2. Install SDK Compoenets through SDKManager
  3. Connect the camera and boot developer kit
  4. Run the sample:
    OpenCV Video Capture with GStreamer doesn't work on ROS-melodic - #3 by DaneLLL
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.