Python crashes after cudnn update

Hi,

after updating cudnn I get the folowing output:

2021-11-11 17:04:58.146514: I tensorflow/stream_executor/cuda/cuda_dnn.cc:366] Loaded cuDNN version 8300

Process finished with exit code -1073740791 (0xC0000409)

any reason why?

I have tensorflow of 2.7, cuda 11.5

thanks

2 Likes

Hi @user43227
Can you pls share with us the detailed logs?

Thanks!

Same issue. My tensorflow is 2.6, cuda 11.5

Same issue.

i was troubled by this issue for 3 days and I have tried many ways to solve it but nothing worked.So I have to downgraded my python from 3.9 to 3.6,Cuda from 11.5 to 11.2,tensorflow from 2.6 to 2.5 , and cudnn from a newer version(i forgot it lol) to 8.2.After that it finally worked.

1 Like

I also downgraded cudnn from 11.5 to 11.4 and it works fine. Using tensorflow 2.6

Thanks. I got the same issue. Downgraded as per your suggestion and it worked.

0xC0000409 error → install 11.4 cudnn

Hi @user43227 can you check if you have zlib available in your environment?
This was a new dependency introduced first in cuDNN 8.3.0. See the following guide for getting zlib

1 Like

After I got the problem, I installed exactly 2.8 Tensorflow, exactly 11.2 cuda and exactly 8.1 cuDNN, as it’s written here here: Build from source on Windows  |  TensorFlow
I guess, the main problem is with cuDNN, because with simple forward neural networks everything works, but when I added Convolutional layers, I got the problem.

Right now I reinstalled, as I wrote below, and everything works now

Follow the instruction to install zlib then the problem can be solved. I just tried with the cudnn 8.4.

Thanks for confirming installing zlib worked for you,

Thanks for sharing its working for you