Could not load library cudnn_cnn_infer64_8.dll. Error code 193

I am trying to run Tensorflow on my new GPU GetForce 2060 , but I keep on getting this error:
"Could not load library cudnn_cnn_infer64_8.dll. Error code 193.
I use Windows 10
I downloaded CUDA 11.2, with cuDNN 8.1, which according to your website are compatible. I’m using Tensorflow 2.8.0. I copied all the files from cudnn 8.1 on Bin, exclude and lib as well

I previously downloaded CUDA 11.6, but as I realized it is not supported by cuDNN I uninstalled it, however when I run on the command prompt “nvidia-smi”, I still see CUDA 11.6 as the version found?

Can anyone help?

Thank you !


Please refer to the installation guide and make sure cuDNN is installed correctly.

Thank you.

I used the installation guide to install the versions I listed above. I have been trying resolve the issue for some time,

Please see attaced my NVIDIA-SMI…it shows CUDA11.7, which i don’t believe is compatible wit cuDNN8.4.1., however the CUDA version I installed is 11.2 (see attachement). Also on the Visual studio part from the installation guide: 1. Include cudnn.lib in your Visual Studio project.

  1. Open the Visual Studio project and right-click on the project name.
  2. Click Linker > Input > Additional Dependencies.
  3. Add cudnn.lib and click OK.

I don’t know how to do this…can not find a linker option anywhere…Am I supposed to create a new project?

Please let me know your thoughts


Looks like there is some issue in your CUDA setup, please make sure only one version of CUDA is installed correctly.

We are not sure about this. Please reach out to VS code forum to get better help regarding the above steps.

Thank you.

How do I reach out to Vs Code?

I spent over $500 on your product over a month ago and can not use it. I need someone to read my questions properly and address them accordingly. Please stop sending me links to the installation guide and pasting pieces of it.

To be clear at this point this is not an issue anymore, but rather a complain about your lack of effort on helping me resolving the issue with your product.


Dear Javier, I also found this problem with a RTX3070. To solve it I googled and found that my GPU wasn´t completly compatible with the latest version of CUDNN.
To solve it I downloaded an earlier version of CUDNN (11.2) from here: cuDNN Archive | NVIDIA Developer.
Then I pasted the files from each of the downloaded folder to (each of the corresponding folders) the hard disk folder NVIDIA GPU Computing Toolkit/CUDA/v11.7…
Be carefull to replace the most recent files with the older (newly downloaded) ones. This may sound a bit strange, but for this tasks is not always better to have the most recent version of every file.

I am not a programmer at all, I just an enthusiast Medical Doctor playing around with deep learning.

I hope to be able to help you.

For sure there are more “technically correct” approaches, but this did the trick for me.



Thank you very much for your reply. So if i understand you correctly, you kept CUDA 11.7 but copied the files from CUDNN 8.2 into the 3 cuda 11.7 ones (include, etc…)?

When i realized 11.7 is not compatible with any CUDNN yet, i tried to uninstall cuda 11.7 and installed cuda 11.2…then i copied the cudnn 8.2 files into cuda 11.2. however i still see 11.7 as the vuda version when i run Nvidia SMI on the command line.

That’s right.

Working with GPU support, python 3.8, I had no problems working with Tensorflow on JupyterLab.

Hi @javierdearrese,

Sorry for the inconvenience. We understand your concern.
As you stated that installed CUDA 11.2, we also need to make sure that the cuDNN build matches the installed CUDA version (11.2) along with Tensorflow and also make sure that the cuDNN libs can be found in the python environment.
Please find the following issue similar to this.

Thank you.

I followed all the steps suggested on your link. I installed CUDA 11.4 with cuDNN 8.2.4, copied the files, made sure the PATHs are on the enviroment and still the same ERROR 193. Could not load library cudnn_cnn_infer64_8.dll

what am i missing?


Sorry for the late reply,
Have you installed successfully zlib package ?

3.1.3. Installing Zlib

Zlib is a data compression software library that is needed by cuDNN.


  1. Download and extract the zlib package from ZLIB DLL. Users with a 32-bit machine should download the 32-bit ZLIB DLL.

Note: If using Chrome, the file may not automatically download. If this happens, right-click the link and choose Save link as…. Then, paste the URL into a browser window. If the above link doesn’t work please refer zlibwapi.dll free download | DLL‑ or Download Zlibwapi.dll for Windows 10, 8.1, 8, 7, Vista and XP
Please download 64-bit or 32 bit based on your system.

  1. Add the directory path of zlibwapi.dll to the environment variable PATH.

Please make sure zlib is added to the path.
If you still face this error, please share with us nvidia-smi output and error logs .

Thank you.

this is the error logs. I downloaded the zlibwapi.dll file and copied it into the C:Windows\System32 directory as instructed on the site. I added the path to Enviroment Variables PATH as you said. Still the same error.
I called the Level2 support and left several mesages with my e-mail and cel# but n one has called me back or responded.
Is there a number where I can reach you ?


This is strange.
Error code 193 indicates that a DLL is not in the correct executable format (e.g. corrupted or 32-bit when should be 64 bit). In this context, this could either be cudnn_cnn_infer64_8.dll or zlibwapi.dll .

the zlibwapi files are there,
the paths are there.
Still getting the same error.
However the links you provided for downloading the 64 bit versions are NOT secure. It has been more than 2 months with this and it takes you 2 weeks to provide vage answers that takes me nowhere time after time, IS THERE SOMEBODY ELSE I CAN TALK TO???

We strongly believe that this issue is setup-related (Zlib).
Error in your logs clearly says, unable to access zlibwapi.dll.
This is a setup issue from your end.

We noticed that your System is 32-bit and but you downloaded 2 types of Zlib files. Please delete both of them. Please download only one correct one.

For your convenience, I am attaching zlib files here.

We recommend you to

  • Download the one 64-bit zlib from the link within cuDNN documentation and CONFIRM that it is 64-bit and named correctly (zlibwapi.dll ). I would note that the link we provide is the same link provided by the official zlib page ( - under “Related External Links: zlib for Windows 9x/NT/2000/XP/2003 (DLL version, plus related utilities”). So even if it is not hosted through https, it’s the recommended download link.

  • Also, please copy zlibwapi.dll to “C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA<cuda_version>\bin” - make sure only one CUDA version is installed.

  • Make sure zlib can be found by the loader

  • If the Above fails please try 32-bit as well by deleting the previous file.

For 64-bit → (142.1 KB) - Please use dll_x64\zlibwapi.dll in the zip file

For 32-bit → (182.2 KB) - Please use dll32\zlibwapi.dll in the zip file


Hey, I know this is a really old thread, but since my searching for this problem led me here, I’m posting a breadcrumb for future searchers that might not like the idea of downloading random DLL files from the internet. (although it does seem to be legitimate, just not configured properly)

I found a copy of the 64 bit zlibwapi.dll hiding under a different name in:
C:\Program Files\NVIDIA Corporation\Nsight Systems 2022.4.2\host-windows-x64\zlib.dll

I copied and renamed it to:
C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v11.8\bin\zlibwapi.dll

since that folder is already in my PATH variable; and it worked. Turns out the CUDA Toolkit already has the file you need elsewhere. Seems like they could save a lot of trouble if they just made a change to the CUDA Toolkit installer.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.