ZLIB DLL for latest CUDNN in official install guide is missing

https://docs.nvidia.com/deeplearning/cudnn/install-guide/index.html#install-windows
The 3.1.3 chapter of this guide has a x64 ZLIB DLL link, but it’s a dead link. I visited ZLIB DLL website and there is no link for x64 ZLIB DLL anymore.

3 Likes

Hi @S.C.L thanks for reporting this issue. Are you using Chrome? We are able to repro it on Chrome. In that case, can you try right click on the link and choose “save link as” and see if the download starts?
We will add a note in the documentation about his strange issue.

Hi,
I tried to download this zip folder by right click and “save link as”, this link is still not working. Please help.

In NVIDIA website, they referred to zlibwapi.dll- I was able to locate this file in “C:\Program Files\Microsoft Office\root\Office16\ODBC Drivers\Salesforce\lib” (I installed using Microsoft 365 x64 in windows 11) and copy pasted this file into “C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v11.6\bin” I was able to run Tensorflow 2.8.0 thereafter

6 Likes

you are my hero !!! I saw that DLL mentioned somewhere else but I dismissed it as crazy that an Office DLL would be involved… In desperation I did exactly as you did and Cuda11.6 + cuDNN 8.4 now work. I could use 11.3 / 8.3 fine but that won’t work with VS2022. This is embarrassing for NVidia ! I wasted hours on this. I would come back to it once a week, get frustrated and go back to 11.3. Finally the mystery is solved.

2 Likes

Thanks

Sorry this thread did not get any attention from the NVIDIA support folks, I’ll bring this to them, if there is a dependency, and needs some manual copying it then it needs documentation and ideally this dependency should be avoided.
Thanks again for posting it here and also posting the solution.

This advice Solved my problem (on O.S windows 10) , when I try and download zlibwapi.dll.zip from nvidia docs link, my browser warns me the connection is insecure and dangerous, when I force download and try to extract the zip, I am warned the file is corrupted and cannot use it.

I do not have Microsoft 365 but I searched my programFiles folder and found zlibwapi.dll in another program. I copy and pasted it into
“C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v11.6\bin”, this solved my problem.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.