Quadro P2000 440.64 crash under Ubuntu


My laptop PC crashes when I use an HDMI external 4k monitor at full resolution with 200% zoom.
This is a repeatable behaviour. I’m using Ubuntu. The problem occurs with different versions of the driver and different Ubuntu versions.
I’ve been using at least 390, 435, 440.64, 440.82 under 19.10. 440.64 downloaded from ppa. Latest 440.82 downloaded from nvidia site.
I’m currently using stock repository driver under Ubuntu 20.04 LTS, 440.64 if I’m correct.
If I halve the resolution in both X and Y to 1920x1080 and set zoom to 100%, I have a quite more stable PC.

I have reported a bug to Ubuntu, but it seems that the bug reporting tool fails to send the needed information.
I try sending information using nvidia tool if it may help. The file is gzipped.nvidia-bug-report.log (425.0 KB)

I’m open to advices/tweakings to get the system working.

That rather looks like it’s crashing in the modesetting driver which comes with the Xorg server.

(EE) Backtrace:
(EE) 0: /usr/lib/xorg/Xorg (OsLookupColor+0x13c) [0x55b4fd394dec]
(EE) 1: /lib/x86_64-linux-gnu/libpthread.so.0 (funlockfile+0x60) [0x7fa5c171b41f]
(EE) unw_get_proc_name failed: no unwind info found [-10]
(EE) 2: /usr/lib/xorg/modules/drivers/modesetting_drv.so (?+0x0) [0x7fa5c0572050]
(EE) 3: /usr/lib/xorg/Xorg (xf86_crtc_show_cursor+0x31) [0x55b4fd2a9731]
(EE) 4: /usr/lib/xorg/Xorg (xf86_show_cursors+0x28f) [0x55b4fd2a9a6f]
(EE) 5: /usr/lib/xorg/Xorg (xf86DestroyCursorInfoRec+0xa83) [0x55b4fd2b5113]
(EE) 6: /usr/lib/xorg/Xorg (xf86DestroyCursorInfoRec+0xecd) [0x55b4fd2b5a1d]
(EE) 7: /usr/lib/xorg/Xorg (RamDacHandleColormaps+0x765) [0x55b4fd2b3a95]
(EE) 8: /usr/lib/x86_64-linux-gnu/nvidia/xorg/nvidia_drv.so (nvidiaAddDrawableHandler+0x46d856) [0x7fa5c0efc9ac]
(EE) Segmentation fault at address 0x0

Does it work when you switch to intel only?

It does not crash when I use intel driver.

I set the intel driver this way :
sudo prime-select intel

Apparently, it needs a reboot to switch because if I try to set the resolution/zoom to 4k/200% just after prime-selecting, it crashes. It doesn’t crash after the reboot even if I change to resolution several times. It crashes every time with the nvidia driver selected.

The crash looks like it’s a variant of
Looks like this is alway happening in a PRIME output config.

For a workaround, you could upgrade to 20.04 and use the on-demand profile, i.e. running the desktop on the intel and start applications on the nvidia when needed.

Ok, did some testing and it seems it is the same bug. In PRIME output mode, the Xserver is always crashing for me if the cursor size is set to larger than 64. Setting the zoom to 200% effectively doubles the size.
cursor 96 ->instant crash
cursor 64-> works->setting zoom 200%->crash
cursor 24->works->setting zoom 200%->works
Numerical cursor size in gnome:


Thanks, well spotted.
As a matter of fact, you remind me that I had issues with mouse pointer painting and crashes one year ago (according to my notes) when I tried to set the mouse pointer to max size.
Using dconf setting size to 31 before changing resolution and zoom ratio worked well around the crash.
Wait and see to see if it’s stable or if I hit other problems.
Thanks again.

Please update your Ubuntu bug report with info from this thread and also mail the nvidia-bug-report.log with a description of this bug to linux-bugs[at]nvidia.com since this is an annoying bug that ought to be fixed rather than worked around.

Already updated the Ubuntu bug :)
Going to mail the bug report [edit: done].

Thank you for updating your Ubuntu bug report @SR_SR this should be patched by the Ubuntu 20.04.1 point release which due in about 2 months in Mid-July.

1 Like

I confirm that my system does not crash anymore with 450.66 from current 20.04.1 LTS when I try to set a bigger value than 31 in 200% zoom with UHD resolution.
I tried many values, and I can see that the pointer size does not increase even if I try bigger values for the setting.
Actually, if I use Setting GUI and go to the Universal Access > Cursor Size setting, I’m displayed five cursors to choose from. If I select one of the three smallest, the cursor size is immediately set to the selected size. If I select one of the two biggest, the cursor size remains the biggest of the three previous sizes (named « large »).
So it does look like a workaround has been introduced, that prevents crashing, but a real fix needs to be done to use the value set.
Still, this is good there is no more crash.