Max resolution stuck at 1024x768, Ubuntu 16.04 (with all updates), Nvidia GM204GL [Quadro M4000], nvidia-390 driver

Hi, I’m running Ubuntu 16.04 with all the updates and as of recently my max resolution is stuck at 1024x768. I’m not sure what exactly went wrong as several people are using the computer and many times remotely.
I tried changing videocard, cable, screen(that works fine on a different workstation) with no effect.

I tried installing different versions of the driver with no effect.
The Neuveau driver actually manages to detect native screen resolution, but the part of the desktop that is outside of 1024x768 area does not get redrawn when the dialogs close.

The video card is Nvidia GM204GL [Quadro M4000] and the driver currently in use is nvidia-390.

Xrandr does not show me resolutions beyond 1024x768. Forcing the resolution with xrandr did not work.

Does anyone have any idea where to start looking for the problem?
nvidia-bug-report.log.gz (178 KB)

Ah, interesting, the modes are detected by rejected because they are “too large for use-requested virtual screen size (1024x768)”. Does anyone know where to change the user requested virtual screen size?


…because the xorg.conf
specifies that. Remove it.