rdma-ndd slows down boot

Hi Community,

On boot, rdma-ndd is waiting one minute and a half for something. We have VPI CX5 but we actually do not use Infiniband or RDMA.

Is it safe to disable rdma-ndd? It would be great if it was the default when RDMA/IB is not set up though.

May 16 14:31:39 X root[1907]: openibd: Set node_desc for mlx5_3: X HCA-4

May 16 14:32:48 X systemd[1]: rdma-ndd.service: Start operation timed out. Terminating.

May 16 14:32:48 X systemd[1]: rdma-ndd.service: Failed with result ‘timeout’.

May 16 14:32:48 X systemd[1]: Failed to start RDMA Node Description Daemon.

We have Ubuntu 18.04, up-to-date.



Hi Tom,

This service is only applicable when using InfiniBand networks.

In your case, you can safely turn it off so it does not full up your logs / filesystems. You can stop and disable with the following commands.

systemctl disable rdma-ndd.service

systemctl stop rdma-ndd.service