[REGRESSION] [520.56.06][HW DAMAGE] Cannot set fan speed to 0 any longer for Turing/GeForce 1660 Ti

This is the first driver in many years for which I’m unable to stop the fan by running:

$ nvidia-settings -a '[gpu:0]/GPUFanControlState=1' -a '[fan:0]/GPUTargetFanSpeed=0'

ERROR: The current user does not have permission for operation

  Attribute 'GPUFanControlState' (zen:0[gpu:0]) assigned value 1.

    The valid values for 'GPUTargetFanSpeed' are in the range 1 - 100 (inclusive).
    'GPUTargetFanSpeed' can use the following target types: Fan.

Kernel: 5.19.16
GPU: GTX 1660 Ti
Xorg/XFCE/Fedora 36 fully updated

You can now use values between 1 and 24 but they are NOT SAFE. The fan motor can blow up when running at such low speeds.

Please allow 0 again, please disable values from 1 to 24.

@aplattner @amrits


I want to set my fan speed to 0 as well. I can do this on Windows using FanControl, but I can’t via the Linux driver AFAIK.

This was resolved in 525.60.11, great.

They just made it so the min fan speed you can set is whatever min fan speed the BIOS advertises. Previously in 520 it was hard coded to 1-100 if Pascal or 30 - 100 for Ampere or newer. Before 520 it was also hardcoded but it allowed 0-100 values.

But this seems to have issues with it as well. If I set the fan speed to something really low like 3%, the fan will spin up and then turn off in a loop. I’m not sure if this is hurting anything or not but it’s not ideal.

@amrits or @aplattner would it be possible to fix this?

Driver 525.85.05 still allows to set fan speed values between 1 and 24 which it mustn’t do as it leads to HW damage.

This is quite sad as I reported it many months ago: