Resume from suspend freeze - gtx 1060

Here is my system
http://pastebin.com/pYDvyA9Q

Steps with linux mint and 367 drivers:

  1. Run any game , counter strike go. Or launch chrome… open a bunch of tabs maybe.

  2. Suspend system

  3. Wake.

  4. Jerky mouse almost right away everything freezes, you can break out of this by switching to tty1 and back

with 378.09 drivers can not break out of the freeze by switching

I was directed to make a separate topic by mod from this topic
https://devtalk.nvidia.com/default/topic/962231/linux/resume-from-suspend-freezes-system-gtx-970-arch-linux-kernel-4-4-4-7-nvidia-370-/8

Here is my logs

system log

http://pastebin.com/JGfHBYUz

nvidia log

https://drive.google.com/open?id=0B930YT7NkUD1NW1WYTBhLVQwNHM

not spam why is my post hidden ??

I am also seeing this issue.

Reproduction steps:

  1. Plug my HDMI monitor into my Oryx laptop
  2. Start the computer
  3. Suspend the computer
  4. Wake up the computer
  5. Use the computer for anywhere between 2 min and 20 min, eventually applications freeze

Symptoms: Screen flickers and applications freeze after resuming from suspend. Eventually the machine locks up.
NOTE: this error only occurs when I have HDMI plugged into an external monitor.

I am using an Oryx laptop from System 76. My problem seems to be like jjkinas. It does NOT appear to be this problem, known by System 76: http://support.system76.com/articles/backlight-bug/

Some more info on my system

$ uname -a
Linux linux-brick 4.8.0-34-generic #36-Ubuntu SMP Wed Dec 21 17:24:18 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Nvidia config:

Card: GeForce GTX 1060/PCIe/SSE2
Nvidia Driver Version: 375.26

I will paste the output of dmesg the next time I reproduce it. If there are any other commands to run, let me know. Ya’ll should really put a big old button about “how to submit an issue”, fwiw.

Some workarounds, from System76 support (seems to apply to all recent Ubuntu, though). YMMV.

We’ve been tracking this problem on this hardware with this 1060 video card. It’s related to the NVIDIA driver and just the particular hardware, and it’s not completely consistent.

Trying different versions of the NVIDIA driver may help, but we haven’t narrowed down the fix quite yet. We will soon! Until then, if you turn off hardware acceleration in Chrome that will help. Also, in the NVIDIA control panel, in the OpenGL tab, turning off ‘Flipping’ will fix this issue, but introduces video tearing at times. Until we track this down, that’s what we recommend.

Same problem here, but my Oryx came with “Allow Flipping” turned off, so that is not a workaround.

A laptop without working suspend is basically a desktop :( Can we get a fix?