RGB Full Range (0-255) on HDMI

Hi,

In Nvidia Jetson TX2 using HDMI, it seems to only be able to display a limited range (16-235) instead of the full range (0-255).

I saw the same question for TX1 on:
https://devtalk.nvidia.com/default/topic/929507/rgb-full-range-0-255-over-hdmi-/
but couldn’t find anything about TX2.

How can I have RGB full range in HDMI for the TX2?

Hi jrtt,

It should be set to full range by default. Could you try following configuration?
with xorg.conf –

Section "Screen"
              Identifier "Default Screen"
              Monitor "HDMI-0"
         Option "ColorRange" "Full"
         EndSection

Full range got selected(0 to 255).

with xorg.conf –

Section "Screen"
           Identifier "Default Screen"
           Monitor "HDMI-0"
           Option "ColorRange" "Limited"
       EndSection

Limited range got selected. (16 to 235)

We modified xorg.conf to set ColorRange for Full or Limited and didn’t saw any difference between the two.

Configuration used:

# Disable extensions not useful on Tegra. 
Section "Module" 
   Disable     "dri" 
   SubSection  "extmod" 
       Option  "omit xfree86-dga" 
   EndSubSection 
EndSection 

Section "Device"                                                                                                                                                                                                     
   Identifier  "Tegra0"                                                                                                                                                                                             
   Driver      "nvidia"                                                                                                                                                                                             
# Allow X server to be started even if no display devices are connected.                                                                                                                                             
   Option      "AllowEmptyInitialConfiguration" "true"                                                                                                                                                              
EndSection 

# RGB Limited fix 
Section "Screen" 
   Identifier "Default Screen" 
   Monitor "HDMI-0" 
   Option "ColorRange" "Full" 
EndSection

Is this configuration correct? If so, what else can be causing this issue?

Hi jrtt,

Which BSP are you using? Also, I think you are sure your monitor has full range RGB support, right?
Could you paste the display edid?

Hi WayneWWW,

We rechecked the pipeline, and TX2 is sending full range by default. The issue was in the video input for TX2 that was being acquired with RGB limited range. I fixed that and is working fine now.

Thank you very much for your support.