Rigid Body running on GPU in Create


I am testing the warehouse sample on my omniverse.
But I found that when I finishing setting and pressing the “Play” button, the utilization of GPU dropped from 80%-95% to 20%, and the frame rate of the simulation looks very low.
It looks like the program didn’t use full GPU on simulation.
Is there anything I miss to set on this sample?
Before rigid body simulation

During rigid body simulation

OS version: Windows 10 Pro
Omniverse Create version: 2022.1.2
GPU: RTX A5000
GPU Driver version: 512.78

Thank you very much.

yes we are aware of issues when single GPU is used for simulation. There are a couple of things to improve the performance.

  1. Please make sure for massive simulation you enable omni.physx.flatcache extension to avoid USD writes
  2. It can help to use currently active cuda context, in the Edit->Preferences->Physics you can enable the usage of active cuda context, this requires a restart
  3. By default the simulation runs synchronously, this is causing a lot of stalls, for the GPU simulation its better to run in asynchronous mode to avoid locks. If you select the physicsScene prim in the advanced section you can enable asynchronous simulation.

Hope these tips help! We are working on improving the situation in next release.

Hello @AlesBorovicka ,

Thank you for the reply.
The simulation of warehouse model worked fine after I followed point 1 and 2.
Thank you very much.

Frank Liu

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.