rpm dependency missing when trying to install cuda v9+ on centos7

hi,
was trying to install cuda v9.1, v9.2 and v10.0
it says that nvidia-driver-libs require the rpm libglvnd-gles(EPEL) and it can’t find it.
when trying to look for it in centos repositories the web page does not come up - https://centos.pkgs.org/7/epel-x86_64/libglvnd-gles-1.0.1-0.1.git5baa1e5.el7.x86_64.rpm.html

https://pkgs.org/download/libglvnd-gles

https://centos.pkgs.org/7/epel-x86_64/libglvnd-1.0.1-0.1.git5baa1e5.el7.x86_64.rpm.html

it’s ruining the centos compatibility with cuda, please help

Did you add (enable) the EPEL repositories?

https://www.liquidweb.com/kb/enable-epel-repository/

yea sure,
check the repo out… the rpm does not exists

https://dl.fedoraproject.org/pub/epel/7/x86_64/Packages/l/

libglvnd-gles is not here

appears to have been yanked a few days ago:

https://bugzilla.redhat.com/show_bug.cgi?id=1644446

possibly coincident with RHEL 7.6 release, which seems to have been on October 30, 2018.

https://access.redhat.com/articles/3078

If history is any guide, CentOS 7.6 may be available in a month or so:

https://en.wikipedia.org/wiki/CentOS

okay, thank you very much!
will try to find it in other unupdated repos for now or from RedHat.

I’m having the same issue - I can’t find the libglvnd library for CentOS7(.5). Is there a workaround for this or am I stuck?

This is a known issue at this time. NVIDIA is working on a fix. I don’t have a timeline for the fix or details on what the fix would look like, or when it might be available.

In the meantime, the suggested workaround is to use the CUDA runfile installer instead of the package manager method.

If you want to still use the RPM method for the CUDA toolkit, it should also be possible to avoid this by installing the driver with the runfile installer (either from CUDA toolkit runfile isntaller, or a standalone driver installer) and then only install the toolkit part of the package (yum install cuda-toolkit-10-0). Note that the driver install requires kernel headers (or sources) and one method to get these would be yum install kernel-devel.

https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html

Okay, thanks for the quick reply. Since I’ve already tried to use the package installer and it errored out, what is the procedure from this point? Do I uninstall (rpm -e) the CUDA toolkit (all of it) then use the runfile installer or just run the runfile installer from where I’m at now?

BTW, I’ve already installed the kernel-devel & kernel-headers as part of the video driver install.

Your procedure, do I have this right:

1a. Uninstall ?? “rpm -e cuda-repo-rhel7-10.0.130-1.x86_64” – maybe not because I still need the repo
1b. runfile install (cuda_10.0.130_410.48_linux.run)…
2. “yum install cuda-toolkit-10-0” For just the toolkit?

If you switch from a package manager method to do the driver install to a runfile installer method, you must follow the instructions in section 2.7 of the linux install guide that I’ve already linked. In short, you need to clean out all old package manager installs, to use the runfile installer method.

all as root:

  1. as written in section 2.7:

yum remove <package_name>

where you replace <package_name> with any previous cuda packages installed. If you don’t know what these are or don’t know the history of the machine, it may require additional effort to inspect the installed packages. Or you could do a clean load of the OS.

  1. install the driver (only)

sh cuda_10.0.130_410.48_linux.run

(when prompted, select y for driver install, n for cuda toolkit. However there is no reason I know of that you cannot just install the cuda toolkit this way and be done with it. i.e. y for cuda toolkit)

  1. If you didn’t install the cuda toolkit from the runfile installer in step 2, you should be able to do

rpm -i cuda-repo-rhel7-10-0-local-10.0.130-410.48-1.0-1.x86_64.rpm
yum clean all
yum install cuda-toolkit-10-0

Thanks for your help, I think it’s working…

Hi,

I too have same issue, however, the following workaround didn’t work for me.

rpm -i cuda-repo-rhel7-10-0-local-10.0.130-410.48-1.0-1.x86_64.rpm
yum clean all
yum install cuda

here is what I am getting, Can you help please?

nvidia-smi

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

That problem is because your GPU driver is not correctly installed. It has nothing to do with the issue in this thread. Please start a new thread if you wish to discuss it. If you continue to post unrelated items in this thread I will delete them.

Hi,

It looks to me same issue. cuda installation failing on the following and even just for the drivers too.

yum install cuda-drivers-410.48-1.x86_64

–> Finished Dependency Resolution
Error: Package: 3:nvidia-driver-libs-410.72-1.el7.x86_64 (cuda)
Requires: libglvnd-gles(x86-64) >= 0.2
Error: Package: 3:nvidia-driver-libs-410.72-1.el7.x86_64 (cuda)
Requires: libglvnd-egl(x86-64) >= 0.2
Error: Package: 3:nvidia-driver-libs-410.72-1.el7.x86_64 (cuda)
Requires: libglvnd-opengl(x86-64) >= 0.2
Error: Package: 3:nvidia-driver-libs-410.72-1.el7.x86_64 (cuda)
Requires: libglvnd-glx(x86-64) >= 0.2
Error: Package: 3:nvidia-driver-libs-410.72-1.el7.x86_64 (cuda)
Requires: libglvnd(x86-64) >= 0.2
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Yes, that is the issue that is being discussed in this thread.

You’ll note that driver installation failed at that point, and there is a suggested workaround in this thread. At this moment, you have not installed a driver.

If you get to the point of actually running nvidia-smi, you have installed the driver, i.e. you have worked around the dependency issue in this thread.

If your driver install is not working, that is a separate issue. It could be due to any number of reasons, such as not properly cleaning the machine before you did the install. It is definitely not due to the dependency issue being discussed in this thread, because if you were still having the dependency issue, you would not have been able to install a driver. Discussion of issues after the driver installation is complete is not relevant in this thread.

Please start a new thread. You’re welcome to reference this thread if you like.

Hi Rob,

Looks like the dependency issues are resolved. I am able to install the cuda drivers. Thanks for the help.