Installing CUDA 7.5 on RHEL 7.2

I am running RHEL 7.2 as dual mode by burning the IMG to a flashdrive and running it off the 30 day trial.

I have an NVIDIA GeForce GTX750 Ti graphics card on a 64 bit system. I downloaded cuda-repo-rhel7-7-5-local-7.5-18.x86_64.rpm from https://developer.nvidia.com/cuda-downloads and gives me 3 installation steps.

1.sudo rpm -i cuda-repo-rhel7-7-5-local-7.5-18.x86_64.rpm gives me:

warning: cuda-repo-rhel7-7-5-local-7.5-18.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 5c37d3be: NOKEY
package cuda-repo-rhel7-7-5-local-7.5-18.x86_64 is already installed

2.sudo yum clean all gives me

Loaded plugins: langpacks, product-id, subscription-manager
Cleaning repos: cuda-7-5-local rhel-7-server-rpms
Cleaning up everything

  1. sudo yum install cuda gives me

Loaded plugins: langpacks, product-id, subscription-manager
cuda-7-5-local | 2.5 kB 00:00
rhel-7-server-rpms | 3.7 kB 00:00
(1/2): cuda-7-5-local/primary_db | 26 kB 00:00
(2/2): rhel-7-server-rpms/7Server/x86_64/primary_db | 22 MB 00:56
(1/2): rhel-7-server-rpms/7Server/x86_64/group_gz | 134 kB 00:01
(2/2): rhel-7-server-rpms/7Server/x86_64/updateinfo | 1.2 MB 00:02
Resolving Dependencies
–> Running transaction check
—> Package cuda.x86_64 0:7.5-18 will be installed
–> Processing Dependency: cuda-7-5 = 7.5-18 for package: cuda-7.5-18.x86_64
–> Running transaction check
—> Package cuda-7-5.x86_64 0:7.5-18 will be installed
–> Processing Dependency: cuda-toolkit-7-5 = 7.5-18 for package: cuda-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-runtime-7-5 = 7.5-18 for package: cuda-7-5-7.5-18.x86_64
–> Running transaction check
—> Package cuda-runtime-7-5.x86_64 0:7.5-18 will be installed
–> Processing Dependency: cuda-nvrtc-7-5 = 7.5-18 for package: cuda-runtime-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-npp-7-5 = 7.5-18 for package: cuda-runtime-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-cusparse-7-5 = 7.5-18 for package: cuda-runtime-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-cusolver-7-5 = 7.5-18 for package: cuda-runtime-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-curand-7-5 = 7.5-18 for package: cuda-runtime-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-cufft-7-5 = 7.5-18 for package: cuda-runtime-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-cudart-7-5 = 7.5-18 for package: cuda-runtime-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-cublas-7-5 = 7.5-18 for package: cuda-runtime-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-drivers >= 352.39 for package: cuda-runtime-7-5-7.5-18.x86_64
—> Package cuda-toolkit-7-5.x86_64 0:7.5-18 will be installed
–> Processing Dependency: cuda-visual-tools-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-samples-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-nvrtc-dev-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-npp-dev-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-misc-headers-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-license-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-driver-dev-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-documentation-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-cusparse-dev-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-cusolver-dev-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-curand-dev-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-cufft-dev-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-cudart-dev-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-cublas-dev-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-core-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Processing Dependency: cuda-command-line-tools-7-5 = 7.5-18 for package: cuda-toolkit-7-5-7.5-18.x86_64
–> Running transaction check
—> Package cuda-command-line-tools-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-core-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-cublas-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-cublas-dev-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-cudart-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-cudart-dev-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-cufft-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-cufft-dev-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-curand-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-curand-dev-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-cusolver-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-cusolver-dev-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-cusparse-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-cusparse-dev-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-documentation-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-driver-dev-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-drivers.x86_64 0:352.39-0 will be installed
–> Processing Dependency: xorg-x11-drv-nvidia-libs(x86-64) >= 1:352.39 for package: cuda-drivers-352.39-0.x86_64
–> Processing Dependency: xorg-x11-drv-nvidia-gl(x86-64) >= 1:352.39 for package: cuda-drivers-352.39-0.x86_64
–> Processing Dependency: xorg-x11-drv-nvidia-devel(x86-64) >= 1:352.39 for package: cuda-drivers-352.39-0.x86_64
–> Processing Dependency: xorg-x11-drv-nvidia >= 1:352.39 for package: cuda-drivers-352.39-0.x86_64
–> Processing Dependency: nvidia-uvm-kmod >= 1:352.39 for package: cuda-drivers-352.39-0.x86_64
–> Processing Dependency: nvidia-kmod >= 1:352.39 for package: cuda-drivers-352.39-0.x86_64
—> Package cuda-license-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-misc-headers-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-npp-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-npp-dev-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-nvrtc-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-nvrtc-dev-7-5.x86_64 0:7.5-18 will be installed
—> Package cuda-samples-7-5.x86_64 0:7.5-18 will be installed
–> Processing Dependency: mesa-libGLU-devel for package: cuda-samples-7-5-7.5-18.x86_64
–> Processing Dependency: libXmu-devel for package: cuda-samples-7-5-7.5-18.x86_64
–> Processing Dependency: libXi-devel for package: cuda-samples-7-5-7.5-18.x86_64
–> Processing Dependency: libX11-devel for package: cuda-samples-7-5-7.5-18.x86_64
–> Processing Dependency: freeglut-devel for package: cuda-samples-7-5-7.5-18.x86_64
—> Package cuda-visual-tools-7-5.x86_64 0:7.5-18 will be installed
–> Running transaction check
—> Package freeglut-devel.x86_64 0:2.8.1-3.el7 will be installed
–> Processing Dependency: freeglut = 2.8.1-3.el7 for package: freeglut-devel-2.8.1-3.el7.x86_64
–> Processing Dependency: libGL-devel for package: freeglut-devel-2.8.1-3.el7.x86_64
–> Processing Dependency: libglut.so.3()(64bit) for package: freeglut-devel-2.8.1-3.el7.x86_64
—> Package libX11-devel.x86_64 0:1.6.3-2.el7 will be installed
–> Processing Dependency: pkgconfig(xcb) >= 1.1.92 for package: libX11-devel-1.6.3-2.el7.x86_64
–> Processing Dependency: pkgconfig(xproto) for package: libX11-devel-1.6.3-2.el7.x86_64
–> Processing Dependency: pkgconfig(xcb) for package: libX11-devel-1.6.3-2.el7.x86_64
–> Processing Dependency: pkgconfig(kbproto) for package: libX11-devel-1.6.3-2.el7.x86_64
—> Package libXi-devel.x86_64 0:1.7.4-2.el7 will be installed
–> Processing Dependency: pkgconfig(xfixes) for package: libXi-devel-1.7.4-2.el7.x86_64
–> Processing Dependency: pkgconfig(xext) for package: libXi-devel-1.7.4-2.el7.x86_64
—> Package libXmu-devel.x86_64 0:1.1.2-2.el7 will be installed
–> Processing Dependency: pkgconfig(xt) for package: libXmu-devel-1.1.2-2.el7.x86_64
—> Package mesa-libGLU-devel.x86_64 0:9.0.0-4.el7 will be installed
–> Processing Dependency: gl-manpages for package: mesa-libGLU-devel-9.0.0-4.el7.x86_64
—> Package nvidia-kmod.x86_64 1:352.39-2.el7 will be installed
–> Processing Dependency: dkms for package: 1:nvidia-kmod-352.39-2.el7.x86_64
—> Package nvidia-uvm-kmod.x86_64 1:352.39-3.el7 will be installed
–> Processing Dependency: dkms for package: 1:nvidia-uvm-kmod-352.39-3.el7.x86_64
—> Package xorg-x11-drv-nvidia.x86_64 1:352.39-1.el7 will be installed
—> Package xorg-x11-drv-nvidia-devel.x86_64 1:352.39-1.el7 will be installed
—> Package xorg-x11-drv-nvidia-gl.x86_64 1:352.39-1.el7 will be installed
—> Package xorg-x11-drv-nvidia-libs.x86_64 1:352.39-1.el7 will be installed
–> Processing Dependency: libvdpau(x86-64) >= 0.5 for package: 1:xorg-x11-drv-nvidia-libs-352.39-1.el7.x86_64
–> Running transaction check
—> Package freeglut.x86_64 0:2.8.1-3.el7 will be installed
—> Package gl-manpages.noarch 0:1.1-7.20130122.el7 will be installed
—> Package libXext-devel.x86_64 0:1.3.3-3.el7 will be installed
—> Package libXfixes-devel.x86_64 0:5.0.1-2.1.el7 will be installed
—> Package libXt-devel.x86_64 0:1.1.4-6.1.el7 will be installed
–> Processing Dependency: pkgconfig(sm) for package: libXt-devel-1.1.4-6.1.el7.x86_64
–> Processing Dependency: pkgconfig(ice) for package: libXt-devel-1.1.4-6.1.el7.x86_64
—> Package libvdpau.x86_64 0:1.1-2.el7 will be installed
—> Package libxcb-devel.x86_64 0:1.11-4.el7 will be installed
–> Processing Dependency: pkgconfig(xau) >= 0.99.2 for package: libxcb-devel-1.11-4.el7.x86_64
—> Package mesa-libGL-devel.x86_64 0:10.6.5-3.20150824.el7 will be installed
–> Processing Dependency: pkgconfig(xshmfence) >= 1.1 for package: mesa-libGL-devel-10.6.5-3.20150824.el7.x86_64
–> Processing Dependency: pkgconfig(libdrm) >= 2.4.38 for package: mesa-libGL-devel-10.6.5-3.20150824.el7.x86_64
–> Processing Dependency: pkgconfig(xxf86vm) for package: mesa-libGL-devel-10.6.5-3.20150824.el7.x86_64
–> Processing Dependency: pkgconfig(xdamage) for package: mesa-libGL-devel-10.6.5-3.20150824.el7.x86_64
—> Package nvidia-kmod.x86_64 1:352.39-2.el7 will be installed
–> Processing Dependency: dkms for package: 1:nvidia-kmod-352.39-2.el7.x86_64
—> Package nvidia-uvm-kmod.x86_64 1:352.39-3.el7 will be installed
–> Processing Dependency: dkms for package: 1:nvidia-uvm-kmod-352.39-3.el7.x86_64
—> Package xorg-x11-proto-devel.noarch 0:7.7-12.el7 will be installed
–> Running transaction check
—> Package libICE-devel.x86_64 0:1.0.9-2.el7 will be installed
—> Package libSM-devel.x86_64 0:1.2.2-2.el7 will be installed
—> Package libXau-devel.x86_64 0:1.0.8-2.1.el7 will be installed
—> Package libXdamage-devel.x86_64 0:1.1.4-4.1.el7 will be installed
—> Package libXxf86vm-devel.x86_64 0:1.1.3-2.1.el7 will be installed
—> Package libdrm-devel.x86_64 0:2.4.60-3.el7 will be installed
—> Package libxshmfence-devel.x86_64 0:1.2-1.el7 will be installed
—> Package nvidia-kmod.x86_64 1:352.39-2.el7 will be installed
–> Processing Dependency: dkms for package: 1:nvidia-kmod-352.39-2.el7.x86_64
—> Package nvidia-uvm-kmod.x86_64 1:352.39-3.el7 will be installed
–> Processing Dependency: dkms for package: 1:nvidia-uvm-kmod-352.39-3.el7.x86_64
–> Finished Dependency Resolution
Error: Package: 1:nvidia-uvm-kmod-352.39-3.el7.x86_64 (cuda-7-5-local)
Requires: dkms
Error: Package: 1:nvidia-kmod-352.39-2.el7.x86_64 (cuda-7-5-local)
Requires: dkms
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Does anyone have a suggestions? I have tried installing the latest drivers but I was having trouble disabling the Nouveau kernel driver. Could this be the issue?

maybe you should install dkms

You have to install the EPEL repository
http://www.tecmint.com/how-to-enable-epel-repository-for-rhel-centos-6-5/