RTSP Deprecation in Deepstream-6.4

Unable to read the RTSP in deepstream-6.4 if it contains user_name and password in deepstream sample apps deepstream-rtsp-in-and-out using the command :

python3 deepstream_test1_rtsp_in_rtsp_out.py -i rtsp://admin:admin@123@192.168.1.205:554/cam/realmonitor?channel=4&subtype=0 -g nvinfer β€” Deprecation error

If I run the command without user_name and password it is giving Unauthorised(401)error

GPU Instance being utilised : Tesla T4
Driver Version: 550.40.07
CUDA Version: 12.4
Camera vendor : CP Plus, Dahua

I tried curl as well as gstreamer command unable to read the rtsp url.


Hello,

I am moving your topics to the Deepstream category for better visibility.

I believe your issue is because you are using @ in your password admin@123, which interferes with the @ in @192.168.1.205:554. Two possible solutions are:

  1. Change your password by removing @ in it.
  2. Use %40 instead of @ when providing the RTSP url for processing in deepstream. In your case the url would become:

rtsp://admin:admin%40123@192.168.1.205:554/cam/realmonitor?channel=4&subtype=0

1 Like

As a supplement, if your password is admin_123, try to use admin%5F123

Thanks @user87838 .I tried with %40 as mentioned it’s working.

1 Like

Thanks @junshengy .It worked.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.