RTX 2060 - Coolbits doesn't enable gpu fan support while using Nvidia-Prime

Hello everyone,

As post title says, i’m facing problems while trying to activate gpu fan support on Nvidia-Prime Xorg configuration and external display. I own an Asus rog strix scar III (G531GV) which comes with an Intel iGPU and nVidia RTX 2060 dGPU. Right now iGPU is not being used at all as i only use RTX to project my laptops display on an external monitor with Nvidia-Prime. I understand that i have to add the “coolbits” option on my Xorg.conf file to enable gpu fan on nvidia-settings (Thermal Settings) panel and manually configure gpu’s fan rpms but that doesnt seem to be the case …

I used the following command to build my xorg.conf file with coolbits support:

sudo nvidia-xconfig --prime --cool-bits=28

xorg.conf contents:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.44

Section "ServerLayout"
   Identifier     "Layout0"
   Screen      0  "Screen0"
   Inactive       "InactiveDevice1"
   InputDevice    "Keyboard0" "CoreKeyboard"
   InputDevice    "Mouse0" "CorePointer"

Section "Files"

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:1:0:0"

Section "Device"
    Identifier     "InactiveDevice1"
    Driver         "modesetting"
    VendorName     "Unknown"

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "AllowEmptyInitialConfiguration" "True"
    Option         "Coolbits" "28"
    SubSection     "Display"
        Depth       24

I’ve tried different values for --cool-bits like 4, 5, 8, 12, 28 but nothing seems to be able to enable gpu fan in nvidia-settings thermal settings panel. I even tried adding cool-bits in Device section but to no avail …

Strange part is that while “Editable Performance Levels” options become available with Coolbits, gpu fan configuration does not as shown in the following screenshots:

nvidia-bug-report.log (2.0 MB)

I’ve uploaded my nvidia-bug-report.log as well in case it helps someone tracking down this issue.

My system specifics are the following:

Laptop model                   : Asus Rog Strix Scar III - G531GV
Installed OS                   : Parrot 4.9 64-bit (full updated)
Kernel                         : Linux parrot 5.6.0-2parrot1-amd64
Nvidia Gpu                     : RTX-2060 6GB
Nvidia-Drivers                 : Latest - Proprietary 440.82

Any help would be greatly appreciated,
Thank you all in advance!

On notebooks, the nvidia gpu does not control any fans, all are controlled by the system bios. I don’t know if control for the second fan on asus devices has yet been implemented in any available software, you could check the asus-nb-wmi kernel module
and its mailing list or asus-fan-control