RTX 2070

Hi,

I have a problem with my eGPU.
I’ve installed a fresh version of ubuntu 18.04, on precission 7530
And I have a Intel card inside like also a NVidia quadro P2000.
This is working very clear, but I want use also a RTX2070 on thunderbolt with RazerCore V2.
I’ve installed nvidia-driver-415
the terminal nvidia-smi see all my NVIDIA cards - this is great :)
But I can’t use RTX2070.
When i Use sudo nvidia-xconfig -a (or just simply nvidia-xconfig), and reboot -ubuntu just freezes, and I can’t login

Don’t use nvidia-xconfig, this doesn’t work for hybrid gpu setups.
The desired setup is a bit more complicated due to now having two dgpus so the Xserver doesn’t know which takes precedence.
If this is possible with your hardware, the most easy way to switch would be in bios switch from hybrid graphics (Optimus) to intel only. Then the 2070 would be used automatically by Ubuntu once the changes are made:
https://devtalk.nvidia.com/default/topic/1046240/linux/egpu-and-intel-nuc-xorg-conf-issues-login-loop-and-hanging-/post/5309167/#5309167
If that isn’t possible, you would have to create a specifically crafted xorg.conf for the 2070 to be used. Which has a downside of the config having to be changed again once you detach the egpu and carry away the notebook.

So I need remove the xcorg.conf file, and "add Option “AllowExternalGpus” “true” "to the /usr/share/X11/xorg.conf.d/10-nvidia.conf??

For starters, yes.

My /usr/share/X11/xorg.conf.d/10-nvidia.conf file looks like that:

Section “OutputClass”
Identifier “nvidia”
MatchDriver “nvidia-drm”
Driver “nvidia”
Option “AllowEmptyInitialConfiguration”
ModulePath “/usr/lib/x86_64-linux-gnu/xorg”
Option “AllowExternalGpus” “true”
EndSection

This is correct??

Beceause still not working.

Did you check if you can disable hybrid graphics in bios?
Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Hi,

After edit /usr/share/X11/xorg.conf.d/10-nvidia.conf I can see GPU-1 on Nvidia-settings, so this is better.
but still I can’t display anything on extended display.

nvidia-bug-report.log.gz (1.44 MB)

Since you didn’t say whether you can switch to intel-only graphics in bios or not, I’ll presume you can’t. So you will have to use an xorg.conf, try this:

Section "ServerLayout"
    Identifier     "layout"
    Screen      0  "nvidia" 0 0
    Inactive       "intel"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    Modeline "1280x720_60.00"  74.48  1280 1336 1472 1664  720 721 724 746  -HSync +Vsync
EndSection

Section "Device"
    Identifier     "intel"
    Driver         "modesetting"
    Option         "AccelMethod" "none"
    BusID          "PCI:0:2:0"
EndSection

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:60:0:0"
    Option         "AllowEmptyInitialConfiguration"
    Option         "AllowExternalGpus" "true"
    Option         "PrimaryGPU" "true"
EndSection

Section "Screen"
    Identifier     "nvidia"
    Device         "nvidia"
    Monitor        "Monitor0"
EndSection

Once you detach the egpu, you’ll have to remove it, you can handle this using a systemd service.

First I’m create a file /etc/X11/xorg.conf with parameters from You - that didn’t work. I can’t login.
Ubuntu just looping logon page.

Then I’m update BIOS and there was a new option- “Switchable Graphics”, but when this option is disabled system wan’t start property

Which settings are available with “Switchable Graphics”? Which did you set it to?
Please create two new nvidia-bug-report.logs, one with the xorg.conf and one with bios switch used without xorg.conf.

On the BIOS I have Option “Switchable Grpahics”, and I can enable with additional option “Discrete Graphics Controller Direct Output Mode”.
But when I disable this option, system wan’t start.
Ubuntu stoping work on clean process.

Now (without xorg.conf) I can see my 2 GPU’s on NVIDIA-settings, but on the system->devices->monitor i don’t see any additional devices.
This is insane…
nvidia-bug-report_enable_BIOS_switchableGPU_all.log.gz (1.45 MB)
nvidia-bug-report_with_xorg_conf.log.gz (1.49 MB)

The bios switch will be of no help, leave it on switchable graphics. Please put the xorg.conf back in place and then create a new nvidia-bug-report.log so I can see what is failing.

I’m just added to my earliest post :)

You have to use the exact xorg.conf from my post #8, not just any. Please delete the xorg.conf you’re currently using, use the one that I posted and create a new nvidia-bug-report.log.

I’m just create again a xorg.conf from Your post… and voila - my extended monitor is working :)

You are amazing!! Very Thank You :)

P.S what should I do, to use 3 extended monitor?
nvidia-bug-report.log.gz (1.51 MB)

Just plug the monitor into the egpu, should work OOTB.
Remember, once you detach the egpu, you’ll have to remove/rename the xorg.conf.

When I plugin monitor to ePGU nothing change.
When I reboot system, my new added monitor is working… but earlier is disable.
System see only two monitors, one from my laptop and one extended.
I want use a 3 extended monitor without monitor on laptop.

Can You help me with that?

Can you see and arrange the monitors in gnome-control-center?

Nope.
I can see only two monitors (one from laptop, second extended).

Please create a new nvidia-bug-report.log with the non-working monitor attached.
Does

xrandr --auto

detect and enable the monitor?