RTX 4070 performs no better than old GTX 1080 and multiple issues with drivers

I have installed a new RTX 4070 (MSI Ventus 2x) and am using it under Ubuntu 22.04.
Multiple benchmarks indicate performance comparable to, or worse than, my previous GTX 1080 (Unigine Superposition, glmark2, Blender). I also observed a couple unexpected things.

  1. The Software & Update> Additional Drivers tab doesn’t list any driver, it says “No additional drivers available”.
  2. lspci lists a card, but not called RTX 4070
⮕ lspci | grep -e VGA
01:00.0 VGA compatible controller: NVIDIA Corporation Device 2786 (rev a1)
  1. This doesn’t return anything:
⮕ ubuntu-drivers devices
  1. nvidia-smi reports an unexpected GPU name, NVIDIA Graphics...

Things I have tried, but still got the same behavior as above

  • I have added repo deb https://ppa.launchpadcontent.net/graphics-drivers/ppa/ubuntu/ jammy main
  • I have purged the NVIDIA drivers with sudo apt autoremove nvidia* --purge
  • I have manually installed drivers ver. 525.105.17, downloading the .run file from https://www.nvidia.co.uk, and then running it

Note that I am not having the same issue under Win 10, on the same PC (dual-boot). Once installed the latest NVIDIA drivers for Windows, the card performs as expected under Win 10.

I am attaching additional information.

Please advise.

nvidia-bug-report.log.gz (54.8 KB)
nvidia-installer.log.gz (6.6 KB)
nvidia-smi.txt (1.7 KB)

I guess the linux driver is behind the windows driver so performance is degraded due to the 4070 being unsupported atm. Not unusual.

I have just found that the drivers downloadable from the NVIDIA web site have been updated to ver. 530.41.03, and those seem to support the RTX 4070: benchmarks I run produced the expected results with them.

Training of a neural net (YOLOv5) with Pythorch 2 also runs OK, running at a tad more than twice the speed that with my old GTX 1080 (holding the same hyperparameters of course).

That release is indicated as new feature branch here https://forums.developer.nvidia.com/t/current-graphics-driver-releases/28500

While waiting for a production branch release on PPA, this will have to make do I guess. Drivers should be available at launch, anyway.

Also see https://forums.developer.nvidia.com/t/rtx-4070-nvidia-driver-nvidia-not-updating-their-cuda-repo/249873

1 Like

It may not be unusual, but it’s not good either. NVIDIA should provide better support for their brand new hardware, it’s not like they are a small company or anything, and it’s not like these graphics cards are cheap either. I think they can do better, updating their repos isn’t a huge ask and yet it’s clearly impacting multiple users.

Edit: With that said, it does seem like finally the newer driver is making it’s way into more repos now: https://i.imgur.com/2pgt08h.png

Edit 2: Then again, it looks like it still prefers to install 530.30.02 instead of 530.41.03, that’s unfortunate: https://i.imgur.com/p8ux9te.png