RTX on crysis 2 remastered

How to enable RTX on 2080 super in crysis 2 remastered? When RTX is turned on in the game, it throws it to the desktop.

Hello @dimak19722 and welcome to the NVIDIA developer forums.

These forums are dedicated to developer discussions and general implementation questions. For game specific questions I think you might be better served on the dedicated Support pages of Crysis or our GeForce specific forums.

That said, I would first try and use the GeForce Experience to optimize the game settings. If that does not help, re-install the game itself as well as the latest NVIDIA driver.

I hope that helps!

1 Like