Can't find the VK_NV_ray_tracing extension on my rtx2080

Hello, as of last week VK_NV_ray_tracing has stopped appearing as a device extension for my rtx2080 despite having tried both updating and downgrading my gpu drivers. Currently I’m using the latest gpu driver and Vulkan sdk.

I’m not completely sure if this is just a Vulkan issue or whether both DX12 and Optix are also broken but (and this may just be incompetency on my part) I wasn’t able to get ray tracing to work in UE4 or the DX12 ray tracing samples

Although when a friend tried running Vulkan Info with his rtx2070, he also wasn’t able to see VK_NV_ray_tracing in the device extensions list so that makes it seem like it’s probably a software issue? Either way what’s the best approach in this situation? Is my gpu broken and I should rma it or is this a software issue? If it wasn’t for my friend’s 2070 also not showing up I’d be pretty sure it’s a hardware issue. Anyway I’ve already tried contacting nvidia support and they just pointed me here after telling me to do the usual “update/downgrade everything”.

Hopefully this can be resolved soon!

Quick update, I got DXR to work so it can’t be my gpu. Which I guess means that vulakn’s lacking rtx support right now. Any chance someone could confirm this and who needs to be bothered so that vulkan gets rtx support again?

have you tried the latest Nvidia driver to check the Vulkan RTX support?

Yes but that wasn’t the issue. I should have posted once I got it working. Basically I was using CLion and had to use the Visual Studio compiler or it wouldn’t work and since CLion’s debugger isn’t compatible with Visual Studio I switched it to MinGW and broke it… So pretty much it broke because I was an idiot and I fixed it by pure accident and got it working. Although Vulkan info still doesn’t show the ray tracing extension so I’m not sure why that’s the case but hey at least my code works!