run the sample application fail

Hi, i ran the sample application as the user guide told with the command
“deepstream-app -c source30_720p_dec_infer-resnet_tiled_display_int8.txt”.
But i got failed and the error is only about:
** ERROR: main:490: Failed to set pipeline to PAUSED
Quitting
App run failed
I have followed the instructions to install all the prerequisites, as well as DeepStream SDK 2.0.
I don’t know how to solve it? Please help me, thanks.

Hi Jianxiangm,
Could you use gst-inspect command to make sure all plugins has been installed correctly?

Thanks
wayne zhu

Hi, Wayne. I have got the list. are they right? Thanks.

➜ ~ gst-inspect
coreindexers: fileindex: A index that stores entries in file
coreindexers: memindex: A index that stores entries in memory
coreelements: valve: Valve element
coreelements: multiqueue: MultiQueue
coreelements: typefind: TypeFind
coreelements: tee: Tee pipe fitting
coreelements: filesink: File Sink
coreelements: queue2: Queue 2
coreelements: queue: Queue
coreelements: output-selector: Output selector
coreelements: input-selector: Input selector
coreelements: identity: Identity
coreelements: funnel: Funnel pipe fitting
coreelements: filesrc: File Source
coreelements: fdsink: Filedescriptor Sink
coreelements: fdsrc: Filedescriptor Source
coreelements: fakesink: Fake Sink
coreelements: fakesrc: Fake Source
coreelements: capsfilter: CapsFilter
staticelements: bin: Generic bin
staticelements: pipeline: Pipeline object

Total count: 3 plugins, 21 features

You can use following command to check whether Nv’s plugin been :

gst-inspect-1.0 | grep nv

There is nothing. But i have installed necessary plugins as user guide told.

sudo apt install
libssl1.0.0
libjpeg8
libgstreamer1.0-0
gstreamer-tools
gstreamer1.0-plugins-good
gstreamer1.0-plugins-bad
gstreamer1.0-plugins-ugly
gstreamer1.0-libav
libgtk-3-0

Follow the steps below to extract and install the DeepStream SDK:

  1. Untar core SDK binaries with the following command:
    sudo tar -xvpf binaries.tbz2 -C /
  2. Add the opencv libraries path to LD_LIBRARY_PATH and export the path in bashrc to make it permanent
    with the following command:
    echo "export LD_LIBRARY_PATH=/lib/:
    LD_LIBRARY_PATH" >> (HOME)/.bashrc

Hello,

Just a note I thought might help here…

In the beginning, it is a bit of a “pain” to get things running together properly and often the real errors are masked behind the cache?

That is, run rm -rf ~/.cache/gstreamer-1.0/ and it usually will show you the real errors behind the scenes. Fix whatever that is (prolly some .so that isn’t found) and you should be good to go.

  • perhaps look at the symbolic link for the Cuvid library
  • verify opencv and tensorrt are found in LD_LIBRARY_PATH (I added the bin to PATH as well, but not entirely certain if this is needed)
  • verify driver version is 396+
  • verify gstreamer deps (depending on the host system, I had to compile and install zlib 1.2.9 manually for things to work)

Anyway, hope it helps, worst case, delete the cache and post the output here again and we can better extrapolate what the problem is. Cheers.

James.

Hi, i run rm -rf ~/.cache/gstreamer-1.0/ and it shows nothing.
And the symbolic, LD_LIBRARY_PATH and zlib 1.2.9 you said are set as guide told.

Hi, i have re-installed it and now i have these nv’s plugin, but it does still not work.

➜ deepstream-app gst-inspect-1.0 | grep nv
ivtc: ivtc: Inverse Telecine
nvvidconv: nvvidconv: nvvidconv
rtponvif: rtponviftimestamp: ONVIF NTP timestamps RTP extension
rtponvif: rtponvifparse: ONVIF NTP timestamps RTP extension
audioconvert: audioconvert: Audio converter
nvinfer: nvinfer: NvInfer
autoconvert: autoconvert: Select convertor based on caps
autoconvert: autovideoconvert: Select color space convertor based on caps
audiofx: audioinvert: Audio inversion
nvtracker: nvtracker: NvTracker plugin
libav: avdec_twinvq: libav VQF TwinVQ decoder
libav: avdec_dsicinvideo: libav Delphine Software International CIN video decoder
libav: avdec_idcinvideo: libav id Quake II CIN video decoder
libav: avdec_wnv1: libav Winnov WNV1 decoder
nvmultistream: nvstreammux: Stream multiplexer
nvmultistream: nvstreamdemux: Stream demultiplexer
nvmultistream: nvmultistreamtiler: Stream Tiler
debugutilsbad: errorignore: Convert some GstFlowReturn types into others
videoconvert: videoconvert: Colorspace converter
bayer: rgb2bayer: RGB to Bayer converter
NvVideoCodecs: nvdec_h264: Nvidia H.264 Video Decoder
NvVideoCodecs: nvdec_h265: Nvidia H.265 Video Decoder
eglglessink: nveglglessink: EGL/GLES vout Sink
nvosd: nvosd: NvOsd plugin
opengl: glcolorconvert: OpenGL color converter
opengl: gleffects_blur: Blur with 9x9 separable convolution Effect
opengl: gleffects_laplacian: Laplacian Convolution Demo Effect
opengl: glviewconvert: OpenGL Multiview/3D conversion filter

I was simply taking ‘shots in the dark’ so-to-speak, as it is difficult to diagnose without more output.

Perhaps share additional information, the more information the easier to provide direction/diagnose

That is, is this running in AWS, what do your PATH, DISPLAY, LD_LIBRARY_PATH env vars look like, whats the output when running the application specifically, before and after removing the registry.bin file, etc…

many vars involved, and its still new so we are all still learning all the things, cheers.

Hi, is there any solution for above problem? I encounter the same issues when trying to execute the command.

I delete the osd and other plugins about display, and it works.
Because i ran on without displayer.

Hi Thinman91,
Could you post your error log?

Thanks
wayne zhu

Hi waynezhu,

This is the error.

Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.
Xlib: extension “GLX” missing on display “:0”.

(gst-plugin-scanner:27169): GLib-CRITICAL **: g_strsplit: assertion ‘string != NULL’ failed

(gst-plugin-scanner:27169): GLib-CRITICAL **: g_strsplit: assertion ‘string != NULL’ failed

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstclutter-3.0.so

Please either:

  • remove it and restart.
  • run with --gst-disable-segtrap --gst-disable-registry-fork and debug.
    Xlib: extension “GLX” missing on display “:0”.
    Xlib: extension “GLX” missing on display “:0”.
    Xlib: extension “GLX” missing on display “:0”.

(gst-plugin-scanner:27194): GLib-CRITICAL **: g_strsplit: assertion ‘string != NULL’ failed

(gst-plugin-scanner:27194): GLib-CRITICAL **: g_strsplit: assertion ‘string != NULL’ failed

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstclutter-3.0.so

Please either:

  • remove it and restart.
  • run with --gst-disable-segtrap --gst-disable-registry-fork and debug.
    ** ERROR: main:490: Failed to set pipeline to PAUSED
    Quitting
    App run failed

Hi thin,

Looks you have not installed all Video related driver.

Thanks
wayne zhu

Hi waynezhu,

I installed all the prerequisites library as in the guide.

Is there any way I can check video related driver which is missing?

Thanks

HI Thin
which tesla product you are using? please download related driver from official website and install, i am using tesla p4, and install driver version 396.26, here is one reference after install:

tse@p4station:~$ dpkg -l|grep nvidia
ii libnvidia-container-tools 1.0.0~alpha.3-1 amd64 NVIDIA container runtime library (command-line tools)
ii libnvidia-container1:amd64 1.0.0~alpha.3-1 amd64 NVIDIA container runtime library
ii nvidia-396 396.26-0ubuntu1 amd64 NVIDIA binary driver - version 396.26
ii nvidia-container-runtime 1.1.1+docker17.12.0-1 amd64 NVIDIA container runtime
ii nvidia-diag-driver-local-repo-ubuntu1604-396.26 1.0-1 amd64 nvidia-diag-driver-local repository configuration files
ii nvidia-docker2 2.0.2+docker17.12.0-1 all nvidia-docker CLI wrapper
ii nvidia-modprobe 396.26-0ubuntu1 amd64 Load the NVIDIA kernel driver and create device files
ii nvidia-opencl-icd-396 396.26-0ubuntu1 amd64 NVIDIA OpenCL ICD
ii nvidia-prime 0.8.2 amd64 Tools to enable NVIDIA’s Prime