Running YoloV8 on Jetson Orin Nano Developer kit

I have been trying to run Yolov8 on Jetson Orin Nano Developer kit 8GB and 32GB Version. The initial step I have done is this,

  1. Downloaded and made initial configurations of Jetpack SDK
  2. After installation, installed ultralytics using pip3 command.
  3. Then just imported Yolo from ultralytics and tried to predict it on a single image and it showed the “Segmentation fault” (Core Dumped Error)

Anyone please help me out this issue.


Have you checked with the sample owner to see if their app can run on Jetson?

Yes, I have attended their webinar and their they discussed regarding using with Jetson Orin nano developer, that’s why I made a try.

from ultralytics import YOLO
model = YOLO(‘’)
results = model.predict(‘1.jpeg’, save = True)

I have just tried this 4 lines of code for which the Terminal promts: Segmentation fault (Core dumped) Kindly please help me to sort this.


Have they tried to deploy it on Orin Nano before?
Did they meet the same Segmentation fault error?

Usually, the segmentation fault is related to a memory issue like invalid access.


No, They have not tested on Jetson Orin Nano Developer Kit, rather with Jetson Nano and Jetson Xavier NX




This sounds like a user-space implementation issue.

It’s recommended to check with the Ultralytics team.
If you want to debug on your own, below is a memory check tool for your reference:

$ sudo /usr/local/cuda/bin/compute-sanitizer --leak-check=full [app]
$ sudo /usr/local/cuda/bin/compute-sanitizer --leak-check=full /usr/local/cuda/samples/0_Simple/vectorAdd/vectorAdd



Please find the below topic for more information about the segmentation fault:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.