Ultralytics on jetson nano

Hello, I´m trying to use yolov8 on jetson nano, I´ve already installed torch, torchvision and was running well, but I installed the python3.8.12 to use ultralytics, and nothing works anymore, the error is ´´´Illegal instruction (core dumped)´´´ when run the file, this occurs on import

Hi @cauanvinicius00, are you able to run python3.8 -c 'import numpy' ?

If so, try running export OPENBLAS_CORETYPE=ARMV8 first (Illegal instruction (core dumped) on import for numpy 1.19.5 on ARM64 · Issue #18131 · numpy/numpy · GitHub)

I did that, but the error to import torch/torchvision/ultralytics is the same

There is some way to use ultralytics in jetson nano JetPack 4.6


@cauanvinicius00 I’m not personally familiar with installing ultralytics on Jetson, but they do have this guide for it:

Had you commented out those torch/torchvision lines from their requirements.txt file as they pointed out in the doc?

yeah, I tried that one, but give another (core dumped) error, @dusty_nv

Those instructions are for Python 3.6, which is what Jetson Nano and JetPack 4/Ubuntu 18.04 natively support. Have you tried just installing PyTorch and torchvision for Python 3.6 first? Does that still give you segfaults?

I am able to use torch and torchvision with Python3.6. In the documentation they ask to run: python3 gen_wts_yoloV5.py -w yolov5s.pt. This current command is given a core dumped for import utils, @dusty_nv

@cauanvinicius00 I’m unfamiliar with their code and unable to say why that may be occurring in their program, you might want to contact their support or file an issue on their GitHub if you already have PyTorch/ect working.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.