SD card not sticking and USB boot

Hello everyone,

So my nano has got a weird problem where the SD card wont stick in its slot and keeps popping out. If I jammed it in, it might work but on next reboot it might not so Its kinda unreliable.

I’ve tried various guides online to get usb boot to work but only had partial success. I am to a point where the nano wont boot directly of a 1TB WD elements external HDD however, if I change the boot record on the sdcard and set sda1 being the primary boot location, it works. Now, this is generally not a big issue since booting from usb does work but in my case where the sd card is not always working, is indeed a problem.

Any suggestions or personal experience are highly appreciated.

SD card wont stick in its slot and keeps popping out.

Sounds like the slot is broken?

Yes, it does seem like it. Tried fixing it but I think there’s no coming back. I’ve managed to get it working by having double sided tape hold the sd card but I’m really looking for an alternative.

No matter how many times I’ve tried booting via a usb, it doesnt wanna work. I’ve followed the official guide to the letter and even some other guides and still. Not sure if that’s due to the HDD not being found at boot.

I don’t really understand your comment now with your first comment here. It seems has conflict. comment #1 says boot from usb is ok, but now usb boot is never ok, which one is correct?

Are you trying to boot from your usb drive on sdcard based jetson nano module with no sdcard connected?

Apologies if my comment confused you. Yes, I’m trying to boot a Jetson nano B01 (the one with the sdcard) off a usb without the sdcard being present.

I thought that this was possible with the release of jetpack 4.5.

Yes, I think it is possible for this only on jetpack4.5. Any release prior to jetpack4.5 still puts the bootloader on sdcard, thus, missing sdcard on those release would cause failure on your case.

But I didn’t see anyone trying this before (even myself), are you sure your QSPI device on module already had those bootloader ?

If you are not sure what is going on, maybe you can share the serial console log. And we can tell you what is wrong.

Yes, I recently got my nano and only used jetpack 4.5.1 so far. On first boot it asked me to flash the QSPI chip so I’m guessing that part is ok.

Will grab logs and post them later today.

Right! I got it working. The problem was exactly what I thought it would be and that’s the USB drive not getting power early enough during the boot process.

It seems that the nano tries to read the boot partition before providing power to the usb ports and in turn it can’t find that partition. The solution was to use an externally powered USB hub so that power flows to the drive before the nano boots. That way, the nano can find the boot drive and proceeds to boot normally. Now the question is, is there a way to force the nano to provide power to the usb ports early?

1 Like

If this issue can be resolved by using external power on HDD, then I would suggest just use that method.

We tried same usb boot on our side but we don’t need extra power for our usb stick.

Which method did you use? Is there a link you can share? I maybe used an older method.

Also, were you using a usb stick or an externa 2.5" hdd?

We use usb stick.