Secondary GIE is not able to load with process mode=1

• Hardware Platform (Jetson / GPU): TITAN X (Pascal)
• DeepStream Version: 5.0
• JetPack Version (valid for Jetson only): None
• TensorRT Version:
• NVIDIA GPU Driver Version (valid for GPU only): 455
• Issue Type( questions, new requirements, bugs): Bug
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Hi, I believe I have found a bug in the common files of the deepstream app. I noticed it while trying to running a secondary GIE on full frame alongside a primary GIE. I had tried placing process-mode=1 in both the main config file and gie config files but the secondary inferencer always ended up with a process-mode=2. That’s when I noticed that in this file: /opt/nvidia/deepstream/deepstream/sources/apps/apps-common/src/deepstream_secondary_gie_bin.c:198, the process-mode sent to gst-nvinfer is actually hard-coded to a value of 2 instead of being read from the config file.

 g_object_set (G_OBJECT (subbin->secondary_gie),
      "config-file-path", GET_FILE_PATH (config->config_file_path),
      "process-mode", 2, NULL);

And I also think it overrides the value set from inside the nvinfer config of the secondary model. For my usecase I had to add a process_mode config parameter, parse it and update the line as follows:

g_object_set (G_OBJECT (subbin->secondary_gie),
      "config-file-path", GET_FILE_PATH (config->config_file_path),
      "process-mode", config->process_mode, NULL);

Please do let me know if this was the right way to fix it. Thanks!

Yeah, you can do like this, but OSD also have one property process-mode, it will conflict with OSD, will forward this to dev team.