Segfault is always reported after parsing ``Resize`` node when convert my customed .onnx


When convert my .onnx by using trtexec, the segfault (‘Segmentation fault (core dumped)’) is always reported after parsing an Resize node. Any help would much appreciated!


TensorRT Version: 8.0.1
GPU Type: Tesla T4 / Jetson NX (Jetpack 4.6)
Nvidia Driver Version: 510.47.03
CUDA Version: 11.6
CUDNN Version:
Operating System + Version: Ubuntu 20.04.2 LTS

Relevant Files:

HERE is my .onnx file.

Steps To Reproduce:

  1. input the command-line below

    /usr/src/tensorrt/bin/trtexec \
        --explicitBatch \
        --minShapes=image:1x3x640x640,scale_factor:1x2 \
        --optShapes=image:8x3x640x640,scale_factor:8x2 \
        --maxShapes=image:8x3x640x640,scale_factor:8x2 \
        --onnx=./test.onnx \
        --saveEngine=./test.engine \
        --workspace=8192 \
  2. then we can find the failed msgs such as:

Request you to share the ONNX model and the script if not shared already so that we can assist you better.
Alongside you can try few things:

  1. validating your model with the below snippet

import sys
import onnx
filename = yourONNXmodel
model = onnx.load(filename)
2) Try running your model with trtexec command.

In case you are still facing issue, request you to share the trtexec “”–verbose"" log for further debugging


  1. My ONNX model has been shared. Plz click the url to download.

  2. I tried the and the result is OK. No error reported.

  3. The trtexec doesn’t working for me. Segfault always reported. I don’t know why.

Please advice. Thanks!


We could reproduce the same error.
Please allow us some time to work on this.

Thank you.


Issue has been fixed as part of Cherry-picked fix to 8.4 OSS: Do not import potential nulltensor for size input in Resize nodes by kevinch-nv · Pull Request #871 · onnx/onnx-tensorrt · GitHub.
Please build the OSS parser to fix your issue.

Thank you.