Serial port and USB Serial adapter not working on Jetson TX2 with Auvidea J120

Hi,

I have one Jetson TX2 on the Auvidea J120 carrier borad, and I am not able to connect to the serial port. I did not found a definite specification of what “/dev/tty…” to use, but read on internet people talking about using “/dev/ttyTHS2”. Y also tried others, but without success.

I am trying to connect to a DJI N3 flight controller. To debug the problem, I tried to connect it to the serial port of an Arduino, with no success either. I also tried to connect the Arduino to a USB port, and no ttyUSB0 or ttyACM0 appeared, so I think there is a problem with the serial driver. How can I fix it?

the result of “cat /etc/nv_tegra_release” is:

R28 (release), REVISION: 2.1, GCID: 11272647, BOARD: t186ref, EABI: aarch64, DATE: Thu May 17 07:29:06 UTC 2018

I flashed the TX2 following the instructions of Auvidea, and everything else is working properly.

Best,

Eduardo Mendes

Unless you’ve installed the board support package for that carrier board not everything will function. Mostly the difference between the default dev board software and the Auvidea will be the device tree. Auvidea will provide that software for their carrier board. Have you installed their device tree? It sounds sort of like you did, but was the tree for the release of L4T/JetPack which you installed?

EDIT: Also, be sure to use settings 115200 8N1 (8 bits, no parity, one stop bit) on your host. Any ttyACM type driver on the host depends on your serial UART cable and not the Jetson.

Thank you linuxdev,

I flashed using the instructions they sent me by e-mail (link: https://drive.google.com/file/d/1zOOFLsZt0zluT-2MYLLKil7xmKgm7sWf/view?usp=sharing), so it should be ok.

The host is ok, because one is the flight controller that works on any computer I tried, and the other (arduino) I tried on my pc and on an odroid, with success.

I did not get what you mean with “Any ttyACM type driver on the host depends on your serial UART cable and not the Jetson.”.

Thank you,

Eduardo Mendes

Much of the logic of the information in your URL is valid on other releases, but the JetPack3.1 release itself is very out of date. If this older release is needed for other software which is not current I suppose you won’t have much choice, but if there is a choice, then you should consider going to something much newer.

When a serial cable connects to the Jetson there is no driver needed at the Jetson side. The USB side does need a driver, and presumably this is connected to some desktop PC and not a Jetson. Which computer has the USB cable connected? That computer needs a driver.

Software which talks to the UART at the Jetson end may have other requirements, but that software will have no knowledge of USB…USB is a “black box” to the UART at the Jetson end.

Both sides of the serial cable communications have to be set to the correct settings such that those settings match. Serial UARTs are not plug-n-play, and thus they won’t know if settings are wrong. UARTs will happily run at whatever setting you tell them to run at regardless of whether it is a compatible setting or not.

What Jetpack version are you using?
For Jetpack 4.2, follow the instructions provided with the Auvidea 2.0 firmware for the J120 on the Auvidea support page. That patch enables all interfaces except the fan control.
For Jetpack 4.2.1 and 4.2.2 you need to patch the kernel files.
Pls see here how I did it.
https://devtalk.nvidia.com/default/topic/1063180/jetson-tx2/run-jetpack-4-2-2-with-auvidea-j120-board-/post/5384265/#5384265

Hi,

I made it work following these 2 videos from jetson hacks (and recompiling the kernel):


Now I am able to use serial /dev/ttyTHS1 with success.

Thank you!