Auvidea J120 TX2 Flashing concerns

  1. I could never put TX2 on USB Recovery mode when mounted on J120 board. I could only do it in Dev Kit.
    The following is my procedure for flashing
./JetPack-L4T-3.1-linux-x64.run

An installation window opens. I choose JetsonTx2 in it. Authenticate. Then the component manger screen shows
I only choose Linux for Tegra Host Side image and its children. All others are set to “no action”.

Accept terms and condition

It proceeds, extracts os image in the disk. I don’t proceed to the final step(when a terminal opens and asks to put Jetson in recovery mode).

cd 64_TX2/Linux_for_tx2
cp ~/ChangesTX2J140_Kernel_r28.1/BCT/* bootloader/t186ref/BCT/

put Jetson TX2 in recovery mode.

sudo ./flash.sh jetson-tx2 mmcblk0p1

Then its flashed

cp ~/ChangesTX2J140_Kernel_r28.1/dtb/* kernel/dtb/

again bring TX2 to recovery mode

sudo ./flash.sh -r -k kernel-dtb jetson-tx2 mmcblk0p1

Now I log in to jetson TX2

sudo cp ~/ChangesTX2J140_Kernel_r28.1/kernel/Image /boot/
sudo cp ~/ChangesTX2J140_Kernel_r28.1/kernel/zImage /boot/
sudo cp -R ~/ChangesTX2J140_Kernel_r28.1/kernel/lib/modules/4.4.38-tegra/* /lib/modules/4.4.38-tegra/
sudo reboot

Even then, I couldn’t get it working.
usb3.0 is not working. its not even detecting mouse and keyboard.
All these works smooth on dev kit. But on j120, it doesn’t work.

Any help please

Hi veshnu,

Have you tried the latest firmware of J120 board? You can find it from https://auvidea.com/firmware/

For USB 3.0: please download the USB3.0 patch for the TX2 and the Auvidea carrier boards.

Thanks

I did try the version 1.4.
should I use USB3.0 patch on top of version 1.4?
According the https://auvidea.com/firmware/

The following patches are included in the firmware above.

USB 2.0: please apply a patch to the device tree to enable USB 2.0
Please replace the line: ‘vbus-2-supply = <0x99>;’
by the following line: ‘vbus-2-supply = <0x19>;’
Alternatively please download sample DTB files with the USB 2.0 patch.
USB 3.0: please download the USB3.0 patch for the TX2 and the Auvidea carrier boards

Hi veshnu,

should I use USB3.0 patch on top of version 1.4?
According the https://auvidea.com/firmware/

Some developers tried it and seems got USB3.0 work, please follow their instruction to download the USB3.0 patch for the TX2.

Thanks

Does anyone have further insight in this problem?

I have the new Jetpack 3.2.1, and the 1.6 version from Auvidea.

I have tried flashing my device several times with their instructions, but it keeps failing (my device says it cannot find the IP address of the board, even though I have it in recovery mode, and I have both connected to wired ethernet.)

And I cannot easily find the IP address of the Jetson since I have no access to a USB (to plug in a mouse or keyboard).

I have tried looking for the USB 3.0 patch, and USB 2.0 patch, but I have been unsuccessful.

I am currently stuck, and I do not know what else to do.

Anyone have more instructions on getting the USB ports on the J120 (with a Jetson TX2) to work?

Thanks!

There are two sets of instructions for getting the USB ports to work.

From https://auvidea.com/firmware/
Firmware packages titled, “auvidea-kernal-J90-J120-v1.6.zip” and “ChangesTX2J140.tar.gz” have txt files with instructions, “flash_via_Jetpack.txt” and “readme.txt” respectively.

As I understand, the zipped firmware package, enables USB2.0 and normal functions, the .tar.gz, enables USB3.0.

I installed both. The instructions specify the files that must be transferred into the Jetpack folder and flashed along with the OS.

After following both sets of instructions, OS flashed to the J120-TX2 system, USB ports are working!

It appears that USB3.0 also works, according to “lsusb”, however I haven’t been able to test with ZED camera because “unable to mount” any drive… but that’s a story for a different thread…

To software670h3:
I get the same error, “cannot find the IP address”. This is normal when using VM as host.
Since USB works, I looked up the IP address and entered it manually, same as for the Dev Kit:

https://devtalk.nvidia.com/default/topic/1002081/jetson-tx2/jetpack-3-0-install-with-a-vm/

For some reason, unlike the with DevKit, the installation will not complete. The error says the information is wrong, however I did the same method with two other DevKits, and it worked fine.

Has anyone been able to get this working with both USB ports on the “auvidea-kernal-J90-J120-v1.6.zip” and “ChangesTX2J140.tar.gz” firmware updates. I have tried numerous ways to do this and I still can’t get either ports to work.

I am trying to get this up and running on a TX2i with a J120 and am having issues. After following the instructions and replacing both the kernel dtb and bootloader files, flashing the board with JetPack 3.2.1 I am in fact able to flash it with the USB ports not working. I am using the “auvidea-kernel-J90-J120-v1.6.zip” and the “ChangesTX2J140.tar.gz” files to get the hardware tree correct.

Any reason why this isn’t working. I am following the instruction set and replacing the files according to
your instructions and on boot nothing works no keyboard or mouse will function on the ports.

The b196 version does not work anymore and cuda fails. The B23 version works with no usb ports active. The b39 version works with no USB ports active. I’ve tried all 3 Jetpack version 3.2, 3.2.1, 3.3.

BELOW IS A BASH FILE I HAVE CREATED TO STREAMLINE THE INSTALL PROCESS. I BELIEVE IT IS CORRECT AND IS MOVING THE FILES CORRECTLY. THIS HAS BEEN CONFIRMED.

Unpack Auvidea kernel and patch files v1.6 for J120 carrier board

cd ~/Downloads
echo Unpack Auvidea J120 Kernel v1.6
unzip -o auvidea-kernel-J90-J120-v1.6.zip

Unpack Auvidea ChangesTX2J140.tar.gz file and follow the instructions

mkdir -p ~/Downloads/ChangesTX2J140
echo Unpacking the ChangesTX2 Update Files…
echo marsden1 | sudo tar xvpf ChangesTX2J140.tar.gz -C ~/Downloads/ChangesTX2J140

Unpack Auvidea USB2.0 sample dtb files

mkdir -p ~/Downloads/TX2_USB2_sample_dtb
echo Unpacking the USB2 Sample DTB Files…
echo marsden1 | sudo tar xvpf TX2_USB2_sample_dtb.tar.gz -C ~/Downloads/TX2_USB2_sample_dtb

Backup files from JetPack 3.2.1 Linux_for_Tegra directory

echo Backup Kernel Files…
mkdir -p ~/Downloads/Backup/kernel
cp -rf ~/Downloads/JetPack-L4T-3.2.1-linux-x64_b23/64_TX2/Linux_for_Tegra/kernel/* ~/Downloads/Backup/kernel
cp ~/Downloads/JetPack-L4T-3.2.1-linux-x64_b23/64_TX2/Linux_for_Tegra/p2771-0000.conf.common ~/Downloads/Backup

Copy new bootloader files into the BCT folder

echo Updating Bootloader Files…
cp -rf ~/Downloads/ChangesTX2J140/tegra186-mb1-bct-pmic-quill-p3310-1000-c0* ~/Downloads/JetPack-L4T-3.2.1-linux-x64_b23/64_TX2/Linux_for_Tegra/bootloader/t186ref/BCT/

Copy new kernel files into the Linux_for_Tegra folder structure

echo Updating Kernel Files…
cp -rf ~/Downloads/auvidea-kernel-J90-J120-v1.6/auvidea_TX2_Jetpack/dtb/* ~/Downloads/JetPack-L4T-3.2.1-linux-x64_b23/64_TX2/Linux_for_Tegra/kernel/dtb/
cp -rf ~/Downloads/auvidea-kernel-J90-J120-v1.6/auvidea_TX2_Jetpack/packages/* ~/Downloads/JetPack-L4T-3.2.1-linux-x64_b23/64_TX2/Linux_for_Tegra/kernel/
cp -rf ~/Downloads/auvidea-kernel-J90-J120-v1.6/auvidea_TX2_Jetpack/p2771-0000.conf.common ~/Downloads/JetPack-L4T-3.2.1-linux-x64_b23/64_TX2/Linux_for_Tegra/
cp -rf ~/Downloads/auvidea-kernel-J90-J120-v1.6/auvidea_TX2_Jetpack/Image ~/Downloads/JetPack-L4T-3.2.1-linux-x64_b23/64_TX2/Linux_for_Tegra/kernel/
cp -rf ~/Downloads/auvidea-kernel-J90-J120-v1.6/auvidea_TX2_Jetpack/zImage ~/Downloads/JetPack-L4T-3.2.1-linux-x64_b23/64_TX2/Linux_for_Tegra/kernel/

Patch the dtb with updated files for USB support

#echo Patching DTB Files…
#cp -rf ~/Downloads/TX2_USB2_sample_dtb/* ~/Downloads/JetPack-L4T-3.2.1-linux-x64_b23/64_TX2/Linux_for_Tegra/kernel/dtb/

Apply binary changes to the filesystem

echo Apply Binary Changes to the Filesystem…
cd ~/Downloads/JetPack-L4T-3.2.1-linux-x64_b23/64_TX2/Linux_for_Tegra/
#chmod 700 apply_binaries.sh
echo marsden1 | sudo ./apply_binaries.sh

Run Jetpack 3.2.1 installation

echo Running JetPack 3.2.1…
cd ~/Downloads/JetPack-L4T-3.2.1-linux-x64_b23
#chmod +x JetPack-L4T-3.2.1-linux-x64_b23.run
./JetPack-L4T-3.2.1-linux-x64_b23.run

Monil

Is the limitation for the J120 Board for the TX2 ONLY as I’m following the instruction set for the TX2i industrial model and the TX2 and TX2i should be built exactly the same except with a higher temperature enclosure and better shock absorption? Is this not the case?

I will try the same procedure with the TX2 standard model that comes with the development kit, but from my experience the Auvidea directions and support are non-existent which is pretty discouraging as we have already went ahead with our designs based on the current carrier board. Any help from the community would be greatly appreciated.