Auvidea J100 USB3.0 on TX2

Hey everyone,

I am trying to flash the TX2 for use with an Auvidea J100. Unfortunately, I am unable to get USB 3.0 working with the Auvidea firmware (https://auvidea.eu/firmware/) and the changes for USB 3.0 compatibility linked on the same page. I would be grateful if you could give me some pointers on how to properly flash the TX2 with the correct firmware for the J100 board. If you feel like one of my approaches (see below) is correct and I should provide more details, please let me know.

I tried the following approaches:

  • Contact Auvidea support - seems to be as atrocious as reported by other users and hasn’t responded in 2 months
  • Try to understand if any of my USB3.0 female A to Micro USB b is faulty - didn’t have any luck testing that though I doubt that that’s the case. Any idea how I could actually verify this?
  • Only use Auvidea’s 2.1 and 2.2. firmware for the J100 (pretty trivial to setup, more or less copy a couple files, run ./apply_binaries.sh) - Result: all devices are detected as USB 2.0 (confirmed via lsusb -t showing 480MB/s)
  • Use Auvidea’s 2.2 firmware for Jetpack 4.2.2 (at least that’s what the folder name suggests) combined with the USB 3.0 patch (see Auvidea’s firmware website) by compiling the sources included in Auvidea’s 2.2 firmware according to https://developer.ridgerun.com/wiki/index.php?title=Compiling_Jetson_TX2_source_code_L4T_32.1 with the USB 3.0 patch, copying over the *cfg files included in the USB3.0 patch into the Jetpack’s BCT folder - Result: tegrabct_v2 fails https://pastebin.com/JuSjeP11
  • Compile L4t 32.1 from sources with USB3.0 patch only according to https://developer.ridgerun.com/wiki/index.php?title=Compiling_Jetson_TX2_source_code_L4T_32.1 and flashing with Jetpack 4.2 - Result: tegrabct_v2 fails: https://pastebin.com/JuSjeP11

Thanks a lot!
Tino

Hi Tino,

I don’t have the answer for this issue, please get the support from Auvidea: https://auvidea.eu/support/

Thanks

Thanks for the reply!

I already tried to contact Auvidea’s support and am still trying to get in touch with them - but as others in this forum also observed, their support tends to be very slow or not respond at all. I was hoping that maybe one of the community members may know how to get USB 3.0 working.

If others with that board would specify which L4T/JetPack release was used, and which device tree and output from “cat /proc/cmdline” occurs, then it might be possible to figure it out from a successful J100 user’s content.

Beware though that any firmware added by Auvidea would be specific to the L4T/JetPack release. Possibly there is more than one revision of that board (I’ve never seen one, not sure), and there could be differences among revisions. One thing you want to be very careful about is to use the L4T/JetPack release the firmware was designed for, and this is actually the first thing I’d check.