"Session expired. Please log in again" when using SDK Manager CLI through Docker


I’m trying to use SDK Manager through docker, as I’m running Ubuntu 22.04 and need Ubuntu 18.04.

# installation of the docker image
docker load -i sdkmanager-
docker tag sdkmanager: sdkmanager:latest 
# checking the installation/version
docker run -it --rm sdkmanager --ver   # result:
# trying to login
docker run -it --rm sdkmanager --query interactive --logintype devzone

But the last command fails with the following message:

Failed to load server data.
Session expired. Please log in again

I was expecting the result displayed in this documentation page: Install with the Command Line — sdk-manager 2.0.0 documentation

Am I doing something wrong?

Make sure your host machine is connected to the internet. If you are using a VM, same. Make sure your VM can connect to the internet. I ran into this issue (same output you have) and it took me way longer to resolve than it should have.

You are right, to connected the Jetson to interet, I used… the ethernet cable of my host PC. So it was not connected when I tried the commands.
So that’s fixed, thank you for your help!

… but I use the occasion to write some extra tips regarding the installation.

The Sdkmanager fails with chroot: failed to run command ‘dpkg’: Exec format error is due to the command generated using --query interactive being incomplete when one wants to flash the Jetson.
As stated in this other page, one must also use the --privileged -v /dev/bus/usb:/dev/bus/usb/ -v /dev:/dev -v /media/$USER:/media/nvidia:slavearguments.

If disk space is a concern, one can use another partition for the downloads using -v /a/folder/on/the/other/partition/:/home/nvidia/Downloads/.

You can be more radical (literally) using this on /home/nvidia but the partition must be in ext3/ext4 since permissions are involved when building/flashing the Jetson OS image (this was a mistake I did like 2 years ago).

When the flashing is done, the Jetson OS starts and the extra installations takes place. The settings for the host-jetson connection are asked, and the default IP was incorrect in my case: I “simply” executed ifconfig on the Jetson to see which IP was used.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.