Set RTX A2000 driver to TCC mode by default

I have a Supermicro AS-2125HS-TNR with a RTX A2000 (12GB) and 24 - 15TB Micron NVMe drives. I’m trying to use software from GRAID to perform GPU accelerated NVMe RAID. When I setup the software it works great and I can get over 100GB/s RAID6 on Ubuntu and 30GB/s Windows 2022. When I reboot the GPU defaults to WDDM mode and the driver fails to load. Nvidia-smi shows error communicating with driver due to server onboard video being primary. I can reboot and change BIOS to external video as default. This allows the driver to load once but subsequent reboots result in driver not loading again. If I change BIOS back and forth between onboard and external, I can get the driver to load each time. That won’t be an option once this server becomes a production Veeam backup repository.

Any way to modify registry to force TCC mode on GPU every reboot? I believe Quadro GPUs default to WDDM mode which I think is the issue.

After some testing, the driver loads and the A2000 is available if I change any setting in the PCIe BIOS settings. It loads once, and then every reboot after the change, the device is unavailable and the driver fails to load. Make any additional change in the BIOS menu for PCIe settings and it loads once more.