Setting up Wi-Fi acess point on TX2

Hello,

I have been trying to setup WiFi access point on my TX2. I have tried everything in this post:

I have also tried everything suggested in other threads but it is still not working!
I have tried with the latest version of JetPack and an older one.

My hostapd.conf looks like:

interface=wlan0
ssid=tx2-hotspot
hw_mode=g
wpa=2
wpa_passphrase=nvidiahotspot
wpa_key_mgmt=WPA-PSK WPA-EAP WPA-PSK-SHA256 WPA-EAP-SHA256
driver=nl80211
country_code=US
wmm_enabled=1
ieee80211n=1
ieee80211ac=1

Here are the error messages.

[ +0.041849] dhd_bus_init: enable 0x06, ready 0x06 (waited 0us)
[ +0.000259] gpio tegra-gpio-aon wake69 for gpio=59(FF:3)
[ +0.005866] gpio tegra-gpio-aon wake69 for gpio=59(FF:3)
[ +0.005317] Enabling wake69
[ +0.006277] wifi_platform_get_mac_addr
[ +0.001174] Firmware up: op_mode=0x0002, MAC=00:04:4b:8c:fa:f1
[ +0.005877] dhd_preinit_ioctls pspretend_threshold for HostAPD failed -23
[ +0.003378] Firmware version = wl0: Feb 4 2017 14:39:11 version 7.35.221.11 (r623264) FWID 01-5b44953
[ +0.002647] dhd_interworking_enable: failed to set WNM info, ret=-23
[ +0.000203] tegra_sysfs_on
[ +0.068720] CFG80211-ERROR) __wl_cfg80211_scan : Invalid Scan Command at SoftAP mode
[ +0.011287] CFG80211-ERROR) wl_cfg80211_scan : scan error (-22)
[ +0.126268] CFG80211-ERROR) wl_cfg80211_del_station : Disconnect STA : ff:ff:ff:ff:ff:ff scb_val.val 3
[ +0.030764] CFG80211-ERROR) wl_cfg80211_set_channel : netdev_ifidx(4), chan_type(1) target channel(1)

What usually happens is that, when I try to connect to my AP, I get incorrect password despite me typing the right one. I tried disabling WPA but I still get the pop-up window asking me to enter a password!?

Is there anything I am missing?
Any help would be appreciated… Thanks!

The passphrase needs to either be put in quotes, or be the hex hash of the passphrase without quotes.

For setting up wifi ap, I always set up one without any security setting to check if hostapd works and then add the security setting.

Thank you for the reply!

Snarky -> I tried passphrase with quotes and that did not do it.

Wayne -> When I set up my AP without any security, I still get asked for a passphrase?

Thanks!

Hi alazarr58cd,

Sorry that I didn’t get it. Have you set up the wifi ap?

I have set it up. But I get “incorrect password” even when I set it up without any security settings.

I have set it up. But I get “incorrect password” even when I set it up without any security settings.

Could you share how you set it up?

I followed this:

Then I tweaked the settings because I was not able to see the wifi ap.
interface=wlan0
ssid=tx2-hotspot
hw_mode=g
wpa=2
wpa_passphrase=nvidiahotspot
wpa_key_mgmt=WPA-PSK WPA-EAP WPA-PSK-SHA256 WPA-EAP-SHA256
driver=nl80211
country_code=US
wmm_enabled=1
ieee80211n=1
ieee80211ac=1

I get incorrect password from my android or iphone.

Here are some of the error messages:
[ +0.068720] CFG80211-ERROR) __wl_cfg80211_scan : Invalid Scan Command at SoftAP mode
[ +0.011287] CFG80211-ERROR) wl_cfg80211_scan : scan error (-22)
[ +0.126268] CFG80211-ERROR) wl_cfg80211_del_station : Disconnect STA : ff:ff:ff:ff:ff:ff scb_val.val 3
[ +0.030764] CFG80211-ERROR) wl_cfg80211_set_channel : netdev_ifidx(4), chan_type(1) target channel(1)

I also tried setting it up using Network Connections:

Thank you for getting back to me!
Please let me know if you need any more information.

HI alazarr58cd,

Please note that any invalid option in your configuration will lead softap fail.

Could you remove following first and see if ap works?

wpa=2
wpa_passphrase=nvidiahotspot
wpa_key_mgmt=WPA-PSK WPA-EAP WPA-PSK-SHA256 WPA-EAP-SHA256

Hi WayneWWW,

I just tried it.

I still get “incorrect password” or “unable to join the network…”. It is very unstable.

Here are the logs for multiple attempts:

CFG80211-ERROR) wl_cfg80211_del_station : Disconnect STA : ff:ff:ff:ff:ff:ff scb_val.val 3
[ +0.011073] CFG80211-ERROR) wl_cfg80211_set_channel : netdev_ifidx(4), chan_type(1) target channel(1)
[ +0.048476] _dhd_wlfc_mac_entry_update():1732, entry(32)
[ +0.044620] _dhd_wlfc_deque_afq: can’t find matching seq(2)
[ +16.604712] CFG80211-ERROR) wl_cfg80211_change_station : WLC_SCB_AUTHORIZE sta_flags_mask not set
[ +0.064107] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH_IND(6) status 0 reason 8
[ +0.009536] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DISASSOC_IND(12) status 0 reason 8
[ +0.009764] CFG80211-ERROR) wl_notify_connect_status_ap :
[ +0.001536] CFG80211-ERROR) wl_cfg80211_del_station :
[ +0.000007] Disconnect STA : 90:b0:ed:c0:70:33 scb_val.val 3
[ +0.008886] event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.000270] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.106752] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.158685] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.014270] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.118495] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.149690] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +2.866848] CFG80211-ERROR) wl_cfg80211_change_station : WLC_SCB_AUTHORIZE sta_flags_mask not set
[ +0.061031] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH_IND(6) status 0 reason 3
[ +0.009420] CFG80211-ERROR) wl_notify_connect_status_ap :
[ +0.002171] CFG80211-ERROR) wl_cfg80211_del_station :
[ +0.000007] Disconnect STA : 90:b0:ed:c0:70:33 scb_val.val 3
[ +0.008220] event WLC_E_DISASSOC_IND(12) status 0 reason 8
[ +11.240481] CFG80211-ERROR) wl_cfg80211_change_station : WLC_SCB_AUTHORIZE sta_flags_mask not set
[Dec 4 22:19] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DISASSOC_IND(12) status 0 reason 8
[ +0.011465] CFG80211-ERROR) wl_cfg80211_del_station : Disconnect STA : 90:b0:ed:c0:70:33 scb_val.val 3
[ +0.005418] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 3
[ +0.013571] CFG80211-ERROR) wl_cfg80211_change_station : WLC_SCB_AUTHORIZE sta_flags_mask not set
[ +0.014841] CFG80211-ERROR) wl_cfg80211_del_station : Disconnect STA : 90:b0:ed:c0:70:33 scb_val.val 3
[Dec 4 22:21] pll_a_out0 = 22579200 Hz, aud_mclk = 11289600 Hz, codec rate = 44100 Hz
[Dec 4 22:22] CFG80211-ERROR) wl_cfg80211_change_station : WLC_SCB_AUTHORIZE sta_flags_mask not set
[ +0.032773] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH_IND(6) status 0 reason 8
[ +0.010897] CFG80211-ERROR) wl_notify_connect_status_ap :
[ +0.003032] CFG80211-ERROR) wl_cfg80211_del_station :
[ +0.000010] Disconnect STA : 8c:85:90:5b:3d:1c scb_val.val 3
[ +0.008079] event WLC_E_DISASSOC_IND(12) status 0 reason 8
[ +0.000560] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.113041] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.140907] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.743911] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +18.732374] CFG80211-ERROR) wl_cfg80211_change_station : WLC_SCB_AUTHORIZE sta_flags_mask not set
[ +5.220366] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DISASSOC_IND(12) status 0 reason 8
[ +0.012338] CFG80211-ERROR) wl_notify_connect_status_ap :
[ +0.000160] CFG80211-ERROR) wl_cfg80211_del_station :
[ +0.000007] Disconnect STA : 90:b0:ed:c0:70:33 scb_val.val 3
[ +0.000584] CFG80211-ERROR) wl_cfg80211_change_station :
[ +0.000004] WLC_SCB_AUTHORIZE sta_flags_mask not set
[ +0.014973] event WLC_E_DEAUTH(5) status 0 reason 3
[ +0.000236] CFG80211-ERROR) wl_notify_connect_status_ap :
[ +0.002620] CFG80211-ERROR) wl_cfg80211_del_station :
[ +0.000007] Disconnect STA : 90:b0:ed:c0:70:33 scb_val.val 3
[ +0.007894] event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.000245] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[Dec 4 22:23] CFG80211-ERROR) wl_cfg80211_change_station : WLC_SCB_AUTHORIZE sta_flags_mask not set
[ +0.016263] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH_IND(6) status 0 reason 8
[ +0.009580] CFG80211-ERROR) wl_notify_connect_status_ap :
[ +0.001151] CFG80211-ERROR) wl_cfg80211_del_station :
[ +0.000008] Disconnect STA : 8c:85:90:5b:3d:1c scb_val.val 3
[ +0.009319] event WLC_E_DISASSOC_IND(12) status 0 reason 8
[ +0.000286] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.185807] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.246743] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.009151] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +0.096386] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DEAUTH(5) status 0 reason 6
[ +20.491342] CFG80211-ERROR) wl_cfg80211_change_station : WLC_SCB_AUTHORIZE sta_flags_mask not set
[ +3.988466] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DISASSOC_IND(12) status 0 reason 8
[ +0.011084] CFG80211-ERROR) wl_cfg80211_del_station :
[ +0.000778] CFG80211-ERROR) wl_notify_connect_status_ap :
[ +0.000009] event WLC_E_DEAUTH(5) status 0 reason 3
[ +0.009735] Disconnect STA : 90:b0:ed:c0:70:33 scb_val.val 3
[ +0.000834] CFG80211-ERROR) wl_cfg80211_change_station : WLC_SCB_AUTHORIZE sta_flags_mask not set
[ +0.013658] CFG80211-ERROR) wl_cfg80211_del_station : Disconnect STA : 90:b0:ed:c0:70:33 scb_val.val 3
[ +12.192007] CFG80211-ERROR) wl_cfg80211_change_station : WLC_SCB_AUTHORIZE sta_flags_mask not set
[ +0.427475] CFG80211-ERROR) wl_notify_connect_status_ap : event WLC_E_DISASSOC_IND(12) status 0 reason 8
[ +0.011836] CFG80211-ERROR) wl_cfg80211_del_station :
[ +0.002346] CFG80211-ERROR) wl_notify_connect_status_ap :

Does the log say anything I am doing wrong? I need to know if this is a hostapd problem or …?
I know the wifi on the board works because I tried connecting to a wifi connection and it was successful.
Thanks again for the speedy response!
–Alazar

This was my configuration in the past. Hope it could work for you.

#/etc/hostapd/hostapd.conf
interface=wlan0
driver=nl80211
hw_mode=a
channel=149 #for Taiwan
ieee80211n=1
ssid=test-AP
auth_algs=1
wpa=2
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
wpa_passphrase=12345678
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0

I am using hostapd utility too and once I run the hostapd, it seems as if like AP is up with the following messages:

hostapd -B /etc/hostapd/hostapd.conf
hostapd: /lib/aarch64-linux-gnu/libnl-genl-3.so.200: no version information available (required by hostapd)
hostapd: /lib/aarch64-linux-gnu/libnl-3.so.200: no version information available (required by hostapd)
Configuration file: /etc/hostapd/hostapd.conf
wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Using interface wlan0 with hwaddr 00:04:4b:8d:80:5e and ssid “Tegra-WLAN”
wlan0: interface state COUNTRY_UPDATE->ENABLED
wlan0: AP-ENABLED

From the messages, it seems AP is up. But the SSID/network does not show up any of my laptop or wifi clients.
Not sure if any one ran into similar issue.

I could not even connect to the SSID on any of my client devices by manually entering the network name and credentials.
The client devices complain saying “No network found with that name”.

Also want to let you know my Tx2 is running Jetpack 3.2 and I loaded some additional J120 drivers as I mounted the Tx2 on J120.

But I could run the Tx2 in client mode (not AP mode) and was able to connect to my local Wifi networks after tweaking the NetworkManager config utilities.

I wonder if you can just directly using NetworkManager GUI to enable it or not.

You only need to choose either hostapd or NetworkManger to enalbe AP. No need to use both.

Have you solved this problem? I have the same, albeit using NetworkManager.

I have the same problem using a NetworkManager or hostapd and I have n’t found any fix yet.
Not sure if there are any fixes in the newest Jetpack in this area?

I solved the problem, see https://devtalk.nvidia.com/default/topic/1044055/wireless-access-point-ssid-keeps-disappearing/?offset=8#5297617

Hi Everyone,

I am trying to setup a wifi hotspot using TX2. I don’t need to bridge connection to ethernet (although that would be a plus). All I want is to create is a local private network between TX2 and my devices.

I was able to follow part of zhirkov’s instruction from https://devtalk.nvidia.com/default/topic/1010353/jetson-tx2/tx2-as-a-wifi-hotspot-/?offset=12#5328438 and get the hotspot up and running using create_ap (https://github.com/oblique/create_ap). However I am unable to get any of my device (Raspberry Pi, Macbook, Android Phones) to connect to it.

Any suggestion would be greatly appreciated! Thank you so much

ddo,

A fast way is to try the GUI from ubuntu to enable wifi ap.