Setuid bit of "/usr/lib/Xorg" and GPU fan speed


I have an Alienware Aurora R11 with a RTX 2080 SUPER inside, and the GPU often falls off the bus when running Linux. A problem that’s plagued me since day one of owning this machine. Nothing is overheating, and my BIOS is up to date.

I think I may have fixed the system freezes by setting PowerMizer to “Prefer Maximum Performance,” and setting coolbits to 12 in an xorg config. However, the idle temperature of the GPU increases to about 63°C.

In an attempt to manually set the GPU fan speed with nvidia-settings, I get an error: “Failed to set new Fan Speed!”

If I set the setuid bit of “/usr/lib/Xorg” I’m no longer locked out of manually setting the GPU fan speed. I don’t feel totally comfortable with the security implications of this. Is there a way to get manual control of the GPU fan speed in nvidia-settings without setting the setuid bit of /usr/lib/Xorg"?


So, that’s a “no” then?


common driver bug with many latest drivers across all systems, use 460.73.01 it works, overclocking and fan control
though its a shame a large company like this cant fix such an issue since mid April

1 Like

We get what we pay for, I guess. Wait… I paid a premium for this NVIDIA card.

Thanks! I’ll try the 460.73.01 drivers right now.

Finally had to time to try out the 460.73.01 drivers. Whenever I try to set the fan speed with NVIDIA X Server Settings, I get the error “Failed to set new Fan Speed!”

I’m right back where I started, apparently. Wondering if I need to go back even further in the driver history…

460.73.01 is not the one to try

Issues were introduced in the following bumps:

  • 465.19.01 (beta but working) → 465.24.01 (fails, if I recall correctly)
  • 460.67 (working) → 460.73.01 (fails)
  • 450.102.04 (working) → 450.119.03 (fails)
  • 390.141 (working) → 390.143 (fails)

And 470.42.01 did the nice thing to enable fan control by default (without coolbits) but is still affected by this.

So, for a stable non-NFB/beta, 460.67 is likely what you want if don’t want root Xorg while waiting for a fix (which I hope is happening).

1 Like

Many thanks! Will try 460.67 out tonight.

The 460.67 drivers give me manual fan speed control without messing with Xorg setuid bits. I lose the ability to set the fan speed manually with the nvidia-settings -a "GPUTargetFanSpeed=x" command, but that is an acceptable compromise for now. I’ll just set it manually with the nvidia-settings GUI.

Thanks, @ionen!
look for the last comment in thread, that solved it for me

From what I understand, chmod +s /usr/lib/Xorg enables the setuid bit for Xorg, and that is what I wanted to avoid in the first place because of it’s security implications.

From @ionen’s solution, I am able to set my fan speeds successfully with nvidia-settings using the 460.67 drivers and Arch Linux (5.12.13-arch1-2) without having to touch setuid bits.

Thank you very much for this! I was going mad as I was not able to use custom fan curves with nfancurve and rendering long sequences was very stressful.

Thanks again!

1 Like

Glad it works!

I’ve been using the 470.57.02 drivers with Arch Linux and the 5.13.13 kernel. No problems to report when it comes to adjusting the fan speeds.

I have not tried the newest driver version as of Aug. 10th, 2021 (470.63.01), but I assume that it should work as well.