Unable to set Fan Speed on the newest 465 Drivers

Okay, so setting up Fan Speed has stopped working for me since version 460.67-1.
It all began when I upgraded from that to 465.24.02-01, and right now i just tried the newer 465.27-1 and the same happened, setting up fan speed always results in: “Failed to set new Fan Speed!”

I checked dmesg and journalctl and found nothing weird about drivers not loading on boot; actually i didn’t find any related errors at all, so after a long investigation on this i’ve decided this can be only Nvidia’s Driver fault.

Im switching back to 460.67-1 permanently. And good luck to nvidia managing to get me into buying a new GPU into the next year. I also tried to use several other kernels I had sitting in here, but nothing. Fallbacking to 460.67 seems to be the only solution so far.

I’ve already wasted a lot of time on this thinking it was either my rig’s fault or my Distro fault.

Here’s My Rig:
Archlinux
GTX 1050ti EVGA
Intel i5 2500k
16GB DDR3 1333Mhz

nvidia-bug-report.log.gz (344.8 KB)

There seems to be a permissions problem with rootless X in the 465 driver:
https://forums.developer.nvidia.com/t/465-24-02-no-longer-able-to-set-graphics-clock-offset-and-memory-transfer-rate-offset/175640/18?u=generix

Thank you srmfsrmf! I had to reinstall 460.67-1 to fix this problem. I wasted so many hours… In a case someone else has the same issue for fedora you can download the old drivers from here “RepoView: "RPM Fusion Fedora nonfree 32 updates - x86_64"” then remove the new ones " sudo dnf remove nvidia*" and install the packages from the folder you have downloaded the old ones " sudo dnf install ./* "

Really. I was ready to throw my graphic card in the trash can!

Here’s the thing, I’ve been running X as Root @generix
That didn’t solve my issue.

You’re welcome! @ftsiadimos :)
On archlinux i had to look for the drivers on the arch archive repository: https://archive.archlinux.org/

Had to re-install all 460.67-1 nvidia related drivers/tools. Here is a small list of the packages I had to downgrade on my Archlinux Distro: nvidia, nvidia-utils, nvidia-dkms, nvidia-settings, lib32-nvidia-utils, lib32-opencl-nvidia, libxnvctrl, opencl-vidia.

@srmfsrmf If you login as root it is working. Verify with the command “ps -o user $(pgrep Xorg)” the user which start the Xorg, you need to be root.
I found this from the below link:

I tried to set the option “needs_root_rights = auto” but it is not working. I can’t find how to allow users…

NVIDIA WHEN YOU CHANGE THIS KIND OF STUFF YOU NEED TO PROVIDE ALSO SOME DOCUMENTATION!! OR MAKE YOUR DRIVERS OPEN SOURCE IF YOU CAN’T SUPPORT THEM! DON"T WASTE PEOPLE TIME AND MONEY!