465.24.02 - No longer able to set Graphics Clock Offset and Memory Transfer Rate Offset

After upgrading to the 465.24.02 driver, I can no longer set the Graphics Clock Offset and Memory Transfer Rate Offset values under PowerMizer in the NVIDIA X Server Settings. The fields are enabled and editable, but when pressing Enter, no changes are applied.

When trying to set these values via the command line, an “Unknown error” is returned.

$ nvidia-settings -c :0 -a "[gpu:0]/GPUMemoryTransferRateOffsetAllPerformanceLevels=1800" -a "[gpu:0]/GPUGraphicsClockOffset[3]=-150"



ERROR: Error assigning value 1800 to attribute 'GPUMemoryTransferRateOffsetAllPerformanceLevels' (jeremy-desktop:0[gpu:0]) as specified in assignment
       '[gpu:0]/GPUMemoryTransferRateOffsetAllPerformanceLevels=1800' (Unknown Error).



ERROR: Error assigning value -150 to attribute 'GPUGraphicsClockOffset' (jeremy-desktop:0[gpu:0]) as specified in assignment '[gpu:0]/GPUGraphicsClockOffset[3]=-150' (Unknown Error).

Does anyone know how I can best debug this issue? To temporarily work around the issue, I attempted to downgrade drivers and linux kernel versions, but I might have had a mismatch, and X would not successfully start.

nvidia-bug-report.log.gz (239.8 KB)

2 Likes

Might be related:

Looks things might broke badly in that area.
What nvidia-settings version are you using?

Didn’t look at your bug-report, but if installing via .run file, always purge the distro packed driver first. If installing the distro driver with the .run file driver installed, always use the --uninstall option of the .run file installer before installing the distro version.

I also installed the nvidia driver on Arch. Here’s the version of nvidia-settings

$ nvidia-settings -v      

nvidia-settings:  version 465.24.02
  The NVIDIA X Server Settings tool.

  This program is used to configure the NVIDIA Linux graphics driver.
  For more detail, please see the nvidia-settings(1) man page.

I was able to downgrade nvidia and linux kernel versions to get this working again. On Arch, this was the command:

sudo pacman -U nvidia-460.67-5-x86_64.pkg.tar.zst nvidia-utils-460.67-1-x86_64.pkg.tar.zst nvidia-settings-460.67-1-x86_64.pkg.tar.zst linux-5.11.11.arch1-1-x86_64.pkg.tar.zst linux-headers-5.11.11.arch1-1-x86_64.pkg.tar.zst
1 Like

I encountered a very similar problem. I update fan speeds in my user xinit (rootless Xorg), and I often leave nvidia-smi running on --loop in some workspace. I saw that after the update, the reported speed was 0%. After manually trying to set it with

nvidia-settings -a "[gpu:0]/GPUFanControlState=1" -a "[fan:0]/GPUTargetFanSpeed=80"

I get

Attribute 'GPUFanControlState' (seath:0[gpu:0]) assigned value 1.

ERROR: Error assigning value 80 to attribute 'GPUTargetFanSpeed' (seath:0[fan:0]) as specified in assignment '[fan:0]/GPUTargetFanSpeed=80' (Unknown Error).

Same version as you, also using the default drivers from the official arch repos:

pacman -Qs nvidia
local/cuda 11.3.0-1
    NVIDIA's GPU programming toolkit
local/egl-wayland 1.1.6-1
    EGLStream-based Wayland external platform
local/lib32-nvidia-utils 465.24.02-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.4-1
    Nvidia VDPAU library
local/libxnvctrl 465.24.02-1
    NVIDIA NV-CONTROL X extension
local/nvidia 465.24.02-3
    NVIDIA drivers for linux
local/nvidia-settings 465.24.02-1
    Tool for configuring the NVIDIA graphics driver
local/nvidia-utils 465.24.02-2
    NVIDIA drivers utilities
local/opencl-nvidia 465.24.02-2
    OpenCL implemention for NVIDIA

Kernel:

uname -a
Linux seath 5.11.15-arch1-2 #1 SMP PREEMPT Sat, 17 Apr 2021 00:22:30 +0000 x86_64 GNU/Linux

One thing I noticed is that I no longer see the Coolbits value when I open the nvidia-settings GUI (even with sudo). I don’t know when it stopped showing though, might be unrelated. Here’s my general config, just in case:

/etc/X11/xorg.conf.d/20-nvidia.conf
Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics 23MP55"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 61.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1060 6GB"
    Option         "Coolbits" "28"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfo" "On"
    Option         "nvidiaXineramaInfoOrder" "HDMI-0 DP-5"
    Option         "MetaModes" "HDMI-0: 1920x1080_60 +0+0 { ForceFullCompositionPipeline = On }, DP-1: 1920x1080_60 +1920+0 { ForceFullCompositionPipeline = On }"
    Option         "MetaModeOrientation" "HDMI-0 LeftOf DP-5"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

More details:

nvidia-smi
Thu Apr 22 00:37:49 2021
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 465.24.02    Driver Version: 465.24.02    CUDA Version: 11.3     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:2D:00.0  On |                  N/A |
|  0%   42C    P8    13W / 200W |    724MiB /  6070MiB |     41%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
nvidia-smi -q -i 0

==============NVSMI LOG==============

Timestamp                                 : Thu Apr 22 00:28:27 2021
Driver Version                            : 465.24.02
CUDA Version                              : 11.3

Attached GPUs                             : 1
GPU 00000000:2D:00.0
    Product Name                          : NVIDIA GeForce GTX 1060 6GB
    Product Brand                         : GeForce
    Display Mode                          : Enabled
    Display Active                        : Enabled
    Persistence Mode                      : Disabled
    MIG Mode
        Current                           : N/A
        Pending                           : N/A
    Accounting Mode                       : Disabled
    Accounting Mode Buffer Size           : 4000
    Driver Model
        Current                           : N/A
        Pending                           : N/A
    Serial Number                         : N/A
    GPU UUID                              : GPU-04b9344d-db93-6d4a-2b42-12fe51fdac3b
    Minor Number                          : 0
    VBIOS Version                         : 86.06.63.00.E2
    MultiGPU Board                        : No
    Board ID                              : 0x2d00
    GPU Part Number                       : N/A
    Inforom Version
        Image Version                     : G001.0000.01.04
        OEM Object                        : 1.1
        ECC Object                        : N/A
        Power Management Object           : N/A
    GPU Operation Mode
        Current                           : N/A
        Pending                           : N/A
    GPU Virtualization Mode
        Virtualization Mode               : None
        Host VGPU Mode                    : N/A
    IBMNPU
        Relaxed Ordering Mode             : N/A
    PCI
        Bus                               : 0x2D
        Device                            : 0x00
        Domain                            : 0x0000
        Device Id                         : 0x1C0310DE
        Bus Id                            : 00000000:2D:00.0
        Sub System Id                     : 0x32811462
        GPU Link Info
            PCIe Generation
                Max                       : 3
                Current                   : 1
            Link Width
                Max                       : 16x
                Current                   : 16x
        Bridge Chip
            Type                          : N/A
            Firmware                      : N/A
        Replays Since Reset               : 0
        Replay Number Rollovers           : 0
        Tx Throughput                     : 0 KB/s
        Rx Throughput                     : 4000 KB/s
    Fan Speed                             : 0 %
    Performance State                     : P8
    Clocks Throttle Reasons
        Idle                              : Active
        Applications Clocks Setting       : Not Active
        SW Power Cap                      : Not Active
        HW Slowdown                       : Not Active
            HW Thermal Slowdown           : Not Active
            HW Power Brake Slowdown       : Not Active
        Sync Boost                        : Not Active
        SW Thermal Slowdown               : Not Active
        Display Clock Setting             : Not Active
    FB Memory Usage
        Total                             : 6070 MiB
        Used                              : 686 MiB
        Free                              : 5384 MiB
    BAR1 Memory Usage
        Total                             : 256 MiB
        Used                              : 7 MiB
        Free                              : 249 MiB
    Compute Mode                          : Default
    Utilization
        Gpu                               : 30 %
        Memory                            : 27 %
        Encoder                           : 0 %
        Decoder                           : 0 %
    Encoder Stats
        Active Sessions                   : 0
        Average FPS                       : 0
        Average Latency                   : 0
    FBC Stats
        Active Sessions                   : 0
        Average FPS                       : 0
        Average Latency                   : 0
    Ecc Mode
        Current                           : N/A
        Pending                           : N/A
    ECC Errors
        Volatile
            Single Bit
                Device Memory             : N/A
                Register File             : N/A
                L1 Cache                  : N/A
                L2 Cache                  : N/A
                Texture Memory            : N/A
                Texture Shared            : N/A
                CBU                       : N/A
                Total                     : N/A
            Double Bit
                Device Memory             : N/A
                Register File             : N/A
                L1 Cache                  : N/A
                L2 Cache                  : N/A
                Texture Memory            : N/A
                Texture Shared            : N/A
                CBU                       : N/A
                Total                     : N/A
        Aggregate
            Single Bit
                Device Memory             : N/A
                Register File             : N/A
                L1 Cache                  : N/A
                L2 Cache                  : N/A
                Texture Memory            : N/A
                Texture Shared            : N/A
                CBU                       : N/A
                Total                     : N/A
            Double Bit
                Device Memory             : N/A
                Register File             : N/A
                L1 Cache                  : N/A
                L2 Cache                  : N/A
                Texture Memory            : N/A
                Texture Shared            : N/A
                CBU                       : N/A
                Total                     : N/A
    Retired Pages
        Single Bit ECC                    : N/A
        Double Bit ECC                    : N/A
        Pending Page Blacklist            : N/A
    Remapped Rows                         : N/A
    Temperature
        GPU Current Temp                  : 43 C
        GPU Shutdown Temp                 : 102 C
        GPU Slowdown Temp                 : 99 C
        GPU Max Operating Temp            : N/A
        GPU Target Temperature            : 83 C
        Memory Current Temp               : N/A
        Memory Max Operating Temp         : N/A
    Power Readings
        Power Management                  : Supported
        Power Draw                        : 14.29 W
        Power Limit                       : 200.00 W
        Default Power Limit               : 200.00 W
        Enforced Power Limit              : 200.00 W
        Min Power Limit                   : 100.00 W
        Max Power Limit                   : 216.00 W
    Clocks
        Graphics                          : 265 MHz
        SM                                : 265 MHz
        Memory                            : 405 MHz
        Video                             : 544 MHz
    Applications Clocks
        Graphics                          : N/A
        Memory                            : N/A
    Default Applications Clocks
        Graphics                          : N/A
        Memory                            : N/A
    Max Clocks
        Graphics                          : 1974 MHz
        SM                                : 1974 MHz
        Memory                            : 4004 MHz
        Video                             : 1708 MHz
    Max Customer Boost Clocks
        Graphics                          : N/A
    Clock Policy
        Auto Boost                        : N/A
        Auto Boost Default                : N/A
nvidia-smi stats -i 0 -c 1
0, pwrDraw , 1619063518376581, 13
0, pwrDraw , 1619063518396728, 13
0, pwrDraw , 1619063518416668, 13
0, pwrDraw , 1619063518436719, 13
0, pwrDraw , 1619063518457526, 13
0, pwrDraw , 1619063518477185, 13
0, pwrDraw , 1619063518497138, 13
0, pwrDraw , 1619063518517078, 13
0, pwrDraw , 1619063518537091, 13
0, pwrDraw , 1619063518557941, 13
0, pwrDraw , 1619063518577664, 13
0, pwrDraw , 1619063518597767, 13
0, pwrDraw , 1619063518617744, 13
0, pwrDraw , 1619063518637706, 13
0, pwrDraw , 1619063518658561, 13
0, pwrDraw , 1619063518678274, 13
0, pwrDraw , 1619063518698230, 13
0, pwrDraw , 1619063518718151, 13
0, pwrDraw , 1619063518738138, 13
0, pwrDraw , 1619063518759064, 13
0, pwrDraw , 1619063518778801, 13
0, pwrDraw , 1619063518798762, 13
0, pwrDraw , 1619063518818709, 13
0, pwrDraw , 1619063518838703, 13
0, pwrDraw , 1619063518859568, 13
0, pwrDraw , 1619063518879152, 13
0, pwrDraw , 1619063518899286, 13
0, pwrDraw , 1619063518919392, 13
0, pwrDraw , 1619063518939551, 13
0, pwrDraw , 1619063518959467, 13
0, pwrDraw , 1619063518979762, 13
0, pwrDraw , 1619063518999860, 13
0, pwrDraw , 1619063519019742, 13
0, pwrDraw , 1619063519039929, 13
0, pwrDraw , 1619063519059944, 13
0, pwrDraw , 1619063519080011, 13
0, pwrDraw , 1619063518095038, 13
0, pwrDraw , 1619063518115046, 13
0, pwrDraw , 1619063518134992, 13
0, pwrDraw , 1619063518155841, 13
0, pwrDraw , 1619063518175536, 13
0, pwrDraw , 1619063518195903, 13
0, pwrDraw , 1619063518215821, 13
0, pwrDraw , 1619063518235645, 13
0, pwrDraw , 1619063518256620, 13
0, pwrDraw , 1619063518276014, 13
0, pwrDraw , 1619063518296061, 13
0, pwrDraw , 1619063518316035, 13
0, pwrDraw , 1619063518336020, 13
0, temp    , 1619063519094164, 41
0, memUtil , 1619063518253961, 27
0, memUtil , 1619063518421825, 26
0, memUtil , 1619063518589681, 26
0, memUtil , 1619063518757328, 26
0, memUtil , 1619063518925256, 26
0, memUtil , 1619063519092880, 26
0, gpuUtil , 1619063518253961, 28
0, gpuUtil , 1619063518421825, 27
0, gpuUtil , 1619063518589681, 27
0, gpuUtil , 1619063518757328, 27
0, gpuUtil , 1619063518925256, 27
0, gpuUtil , 1619063519092880, 27
0, encUtil , 1619063518253961, 0
0, encUtil , 1619063518421825, 0
0, encUtil , 1619063518589681, 0
0, encUtil , 1619063518757328, 0
0, encUtil , 1619063518925256, 0
0, encUtil , 1619063519092880, 0
0, decUtil , 1619063518253961, 0
0, decUtil , 1619063518421825, 0
0, decUtil , 1619063518589681, 0
0, decUtil , 1619063518757328, 0
0, decUtil , 1619063518925256, 0
0, decUtil , 1619063519092880, 0
0, procClk , 1619063518928423, 468
0, procClk , 1619063518928890, 468
0, memClk  , 1619063518928423, 405
0, memClk  , 1619063518928890, 405
0, violPwr , 1619063519097433, 0
0, violThm , 1619063519098135, 0

If anyone finds a solution that doesn’t involve downgrading/rolling back, I’d appreciate. I’m not a cg dev, so the details I provided might be insufficient/irrelevant. If there’s more info I should post, please let me know.

For me, coolbits was still configured, and in the nvidia-smi GUI, the fan settings, graphics clock offset, and memory transfer rate offset were editable, but the changes didn’t appear to take effect.

For me, coolbits was still configured, and in the nvidia-smi GUI, the fan settings, graphics clock offset, and memory transfer rate offset were editable, but the changes didn’t appear to take effect.

Yeah, I’m also able to change the values through the GUI, but they aren’t applied. When I change the Fan Speed slider and click apply, I get a message below the left menu saying: “Failed to set new Fan Speed!”. It’s not a permission problem, the same thing happens when I run nvidia-settings with sudo. Didn’t test clock settings because I don’t care about GPU OC, I just leave it on auto.

Oh, and the fans don’t spin with heavy workloads, they’re just sitting on 0%. It’s strange, because when I turn on the pc they’re spinning. Something weird about this update might be disabling these settings we had access to before

Same bug.

Same bug here, but on driver 460.73.01

Coolbits set to 4, meaning it should allow fan speed to be manually set, however when using either nvidia-settings or GreenWithEnvy, it simply does not set the value at all. In nvidia-settings, it gives me the same error in the bottom left of “Failed to set new Fan Speed!”

I was able to change fan speed using nvidia-xconfig GUI on below configuration setup and also saved/applied it successfully.

Alienware Desktop + Ubuntu 19.04 + Driver 465.24.02 + NVIDIA GeForce RTX 2080

I can only see that user jwmaness has attached bug report but it is missing dmidecode output.
Request everyone to upload bug report to see if issue persists to certain configuration and then I will also try to match my setup to recreate issue locally.

It looks like dmidecode isn’t a dependency of the nvidia Arch package, so I didn’t realize that output was missing when generating the bug report. I’ll get that installed and rerun the bug report. @amrits, what kernel version are you using?

@jwmaness
I had compiled kernel on my previous test system.
I tried again on different setup and still able to change GPU fan speed using nvidia-settings UI.

Precision T7600 + Ubuntu 19.10 + 5.3.0-64-generic + NVIDIA TITAN Xp + 465.24.02

Interesting. 5.3.0-64-generic is a bit older version than linux 5.11.16.arch1-1, so maybe that’s somehow a factor.

Could you try with kernel 5.11 or 5.12 (and possibly Nvidia driver version 460.73) to see if the issue occurs then? I’m having the issue on both kernels with that driver version.

Here’s the nvidia-bug-report with dmidecode output. This is with the 5.11.16-arch1-1 kernel and 465.24.02 driver.

nvidia-bug-report.log.gz (243.6 KB)

I am using Ubuntu 20.10 and 460 when i updated via software update I lost fan control. OC of the core and power limit still works, but fan control is became broken. I decided to install 465 and can’t change anything. went back to 460 via deb. And oc of core works again but fan control is still broken. I am using 5.8.0-50-generic and xanmod 5.11.17. No difference between the two. Is this something that can be fixed with an update or will i have to downgrade. Also would like to mention i use greenwithenvy, but can’t change fan with either xserver or gwe. says failed to set new fan speed!.

Related archlinux bug report: FS#70515 : [nvidia-dkms] GPUTargetFanSpeed does not work on 465.X.X

465.27
I had this problem and still have it with the new version.
However
I’ve read this
https://wiki.archlinux.org/index.php/NVIDIA/Troubleshooting#Overclocking_not_working_with_Unknown_Error
so I thought it might be a problem with gdm which starts Xorg rootless.
installed sddm and plasma to try both gnome and plasma on sddm. and it WORKED IN BOTH (fan,memory overclock,coreoverclock).
I don’t know why this problem appeared now I’ve always used gdm and it still works on older versions of the driver so maybe it’s a packaging trick that used to be done on arch downstream and now it doesn’t or a driver change that re-required root-Xorg.
I’ll post this here and on the arch downstream bug report.

I tried duplicating issue with kernel 5.11 on driver 465.24.02. and 460.73 but no luck.
Precision T7600 + Fedora release 32 + 5.11.16-100.fc32.x86_64 + NVIDIA TITAN Xp + 465.24.02

Highlighting steps tried at my end -

  1. On terminal, ran command nvidia-xconfig --cool-bits=4
  2. opened nvidia-settings, under thermal settings option, enabled GPU Fan Setting and changed fan speed using scroll bar
  3. Apply
    Closed nvidia-settings and reopened again to verify the changed speed.

@amrits
Do you use rootless xorg?

Anyway, xorg under root should never be required for this functionality. So if nvidia has changed this, which seems to be the case atm (affected distros at least arch & ubuntu according to this thread), this should get fixed.

2 Likes