Can't control fan speed with beta driver 349.12

With the recently released beta driver 349.12 i can’t read nor chage the fan speed via nvidia-settings command line or the gui.
This is with a GTX 660 under Ubuntu 15.04.

nvidia-bug-report.log.gz (202 KB)

I too am having this problem with the same driver. Running Linux Mint 17.1 with a GTX 660 Ti. The option for “Enable GPU Fan Settings” is there, but no slider.
nvidia-bug-report.log.gz (208 KB)

No Problem here.

Also have this problem on my GTX 580.

What was the earlier driver worked for you?

346.47

Still not working with 349.16.

[s]After a few minutes of CSGO, nvidia-smi reports this:

±-----------------------------------------------------+
| NVIDIA-SMI 349.16 Driver Version: 349.16 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GeForce GTX 660 Off | 0000:01:00.0 N/A | N/A |
| 27% 94C P0 N/A / N/A | 1198MiB / 2047MiB | N/A Default |
±------------------------------±---------------------±---------------------+

Seems like fan speed is working at minimum speed.

I guess I’ll have to revert back to 346, this driver wants to burn my card.[/s]

Forget this part. Had enabled manaul fan control and that’s probably what was making automatic fan control to fail.

I have the same problem (GTX 680). Just installed 349.16 and now fan settings aren’t working.

When I click “Thermal Settings” it shows fan parameters UI briefly and then it disappears.

Same here for 349.12 and 349.16, GTX 660Ti, OpenSuse 13.1 64bit, used native nvidia .run installer

After update to 349.16 I can’t control fan speed.
http://i.imgur.com/mIqnAGY.png

terminal:

nvidia-settings -a “[gpu:0]/GPUFanControlState=1” -a “[fan:0]/GPUCurrentFanSpeed=80”

Attribute ‘GPUFanControlState’ (ultrahost:1[gpu:0]) assigned value 1.

ERROR: The attribute ‘GPUCurrentFanSpeed’ specified in assignment ‘[fan:0]/GPUCurrentFanSpeed=80’ cannot be assigned (it is a read-only attribute).

Hello, Driver 349.16 - I have the same problem, UBUNTU 14.10 - GTX 660 Ti - Kernel 4.0.

I had to reinstall 346.59 for fan control function.

It is unfortunate that lance defective Nvidia drivers. Greetings.

Arch Linux, kernel 3.19.3, nvidia 349.16,

Fan speed disappears from nvidia-settings after just 1 second.

Confirm the bug
Arch Linux, kernel 3.19.3, nvidia 349.16, gigabyte gtx 670
Fan speed disappears from nvidia-settings after just 1 second.

Automatic fan speed control and manual fan speed control appear broken for me as well.
ArchLinux 64-bit
Linux 3.19.5-1-ck
nvidia 349.16
Fan speed disappears from the control panel after 1 second as above users have stated. Fan speed is non-functional in both automatic and manual modes both with Coolbits enabled and disabled. Thermal throttling occurs when the GPU reaches 80*C as expected, but the performance hit is dramatic. This needs to be addressed.

Hello: If the same fault we reported all, in my case in UBUNTU 14.10. as I have reported before.

I’m on openSUSE Tumbleweed (kernel 3.19.4); nvidia drv. 349.16; gtk970 – and I don’t see the setting at all.

Not sure what I’m missing here, but I don’t think I ever saw that setting while I was on drivers 346.47, 346.59, or 349.12 either, on a variety of distributions I’ve been trying over the past month (Fedora 21, Arch, Ubuntu 14.10).

You won’t see the setting(s) for fan control unless you have

Options "Coolbits" "4"

in your Xorg.conf under the Device or Screen section(s) for you respective graphics card(s)

That said, you can confirm the issue without enabling this using the command line (posted above somewhere) or by monitoring the fan speed and seeing if it increases under load (mine does not increase automatically or manually, which makes this a pretty scary issue)

That’s because you need to enable it first. See Coolbits option http://us.download.nvidia.com/XFree86/Linux-x86_64/346.59/README/xconfigoptions.html.

Thank you very much! I have it now; can’t believe I overlooked this – first graphics card in two decades.