Shader compilation errors after windows 10 update


For the last 3 years I have been developing a desktop application that uses OpenGL. Last week I had a major uptade from windows 10 and since then I am having some issues compiling the shaders of the application. I have tried other machines and they work fine there, but in my laptop they dont.

In some shaders now I am having warnings that I had not before:

WARNING: 0:2: '' :  #version directive missing

And two of the shaders now dont compile. In one of them I dont have any information of the error (glGetProgramInfoLog returns an empty string), and in the other one I have this error:

ERROR: First parameter of atomicCompSwap() should be buffer member or shared.

This is the declaration of the buffer:

layout(std430, binding = 2) buffer solvenergy {ivec4 SolvEnergy[ ];};

and this is the line that crashes:

atomicCompSwap(SolvEnergy[atomToStore].x, prevVal, newVal);

I have tried to download the nvidia driver I had when I bought the laptop but I am still having the same problems. Someone knows what is happening?

Thanks in advance,