Slow SD Card

Hi Wayne,

I noticed that the status is set to disable for this. Also, the file name on the target device under boot directory has changed; it added kernel to the front. kernel_tegra210-p3448-0002-p3449-0000-b00.dtb (237.6 KB)

Alex

Hi Wayne,
Just to make sure that I have done this correctly base on your request. When you have asked for dts file, I copied from boot/kernel_tegra210…dtb of the Nano SOM with custom carrier board. I then converted the dtb file to dts file using a Linux host system and uploaded to you. Is it correct?

When I stated there is a name change, I meant from Jetpack 4.4.1 to Jetpack 4.5.1. I remembered, it used to be just tegra210-p3448-0002…-b00.dtb in the boot directory (no “kernel”).

Just convert the dtb from Linux_for_Tegra/kernel/dtb to me (from your host). This is the path that will be flashed in to your nano. The one under /boot is not the real file either, unless you use FDT to assign path in extlinux.conf.

Hi Wayne,

Thank you for clarification and see attached dts file.tegra210-p3448-0002-p3449-0000-b00.dts (332.1 KB)

Is your vmmc-supply connected to a always-on power source?

If so, also add nvidia,vmmc-always-on to your DT.

Also, where is your cd-gpio?

Hi Wayne,
Yes, power to SD card is always on through 3.3V system. cd-gpio pin is connected to gpio12 of SOM and it is connected to ground (it is a non-removable SD card).

Can you let me know, which DT file? Is it tegra210-p3448-0002-p3449-0000-b00.dts in the /nvidia/nvidia_sdk/JetPack_4.5.1_Linux_JETSON_NANO/Linux_for_Tegra/kernel/dtb folder?

Hi Wayne,

I added vmmc-always-on to the dts file and it detected the sd-card after boot-up. Thank you. Can you help with the speed? I tested the sd card using Gnome Disks and it said 11.8 MB/s. Also, cat /sys/kernel/debug/mmc1/clock is 20MHz.

Thank you Again,

You still need to add cd-gpios to your DT. Why do you need to ask which DT needs to be modified now?

What was your method to add new property to DT?

As for the speed, you can remove the max-clk-limit from sdhci now. That was included in my previous patch on that link.

Hi Wayne,

  1. Can you tell me how to add cd-gpios to DT and what is the value? Also, I was asking which DT file because I am not certain that I am doing it correctly.
  2. I modified the dts file by text editor (assumed it is the DT file that you are referencing). Then compiled it to the dtb file using dtc -Idts -O… After complied the file, I flashed to the Nano with “sudo ./flash.sh -k DTB Jeson-nano-emmc mmcblk0p1.”
  3. For the speed, I will try removing max-clk-limit from the dts file. I noticed that the max-clk-limit was set to 200M.

Write something like below, correct the Z,2 to match the pin on your schematics.

cd-gpios = <&gpio TEGRA_GPIO(Z, 2) 0>;

Hi Wayne,

  1. I tried removing max-clk-limit from the dts file. after flashed SOM, the target board would not start.
  2. After re-flashed with the previous dts file, I also tried cd-gpios, which was set to Y,2 for pin gpio12. Is this correct? Genome speed test showed the same at 11MB/s after added cd-gpios. the sd card was tested on a linux host using the same Disk utility, it is 40MB/s. From dmesg, there is mmc1: tuning execution failed: -5.

Please remember what I said in previous comment.

Please share the dmesg and full dts when you hit any problem with kernel issue. And take this as common sense whenever you are bringing up a custom board.

please see dmesg.
mmc1 execution failed.txt (86.7 KB)

Please use the serial console to dump log, remove the quiet in /boot/extlinux/extlinux.conf, reflash the device tree with cd-gpios and remove the max clk limit.

Htegra210-p3448-0002-p3449-0000-b00.dts (332.3 KB) ere is the dts file.

Hi Wayne,

  1. How to dump a log using serial console?
  2. I did not find quiet in extlinux.conf file in either target nor source/jetpack of a host system. Can you clarify?
  3. Update the device tree (tegra210-p3448-000…dts) by removing the max-clock-limit, is this right?

Thank you for your help,

  1. How to dump a log using serial console?
  1. I did not find quiet in extlinux.conf file in either target nor source/jetpack of a host system. Can you clarify?

What did you find in extlinux.conf? Your boot up log still shows there is a quiet in kernel command line. You can open the dmesg you uploaded and search “quiet” and you will see it.

  1. Update the device tree (tegra210-p3448-000…dts) by removing the max-clock-limit, is this right?

Remove the max clk limit and also add the cd-gpios.