Slow SD Card

I also have slow read/write SD card speed on production SOM (b00) after I have followed the link below.
Link that I have followed: Slow SD card access speed (read+write) with Jetson Nano production module

My System: Production Nano SOM (b00) with custom carrier board.
SDK Manager with Jetpack 4.4.1
SD Card mount permanent (non-removable)
tried by editing tegra210-p3448-0002-p3449-0000-b00.dts file by:
added: sd-uhs-sdr104.50,25, and 12
deleted: max-clk-limit = <400000>;

sudo ./flash -r -k DTB mmcblk0p1

Check dmesg and clock speed:
Did not find "new ultra high speed SDR104 SDXC card " in dmesg
cat /sys/kernel/debug/mmc1/clock: 9,600,000 (not 204MHz)
cat /sys/kernel/debug/mmc1/ios: 9,600,000
cat /sys/kernel/debug/mmc1/speed: 1

This post includes all the patch needed for extra sdcard slot on emmc nano.

Since many users have verified these patch, if your board still not works after adding these, please review your board design.

I could not followed the links because I cannot fined the files and the folders below. Are they in the tar file since I used SDK manager to flash it?
a/hardware/nvidia/platform/t210/common/kernel-dts/t210-common-platforms/tegra210-p2530-common.dtsi 2019-09-18 13:21:25.000000000 +0200
+++ b/hardware/nvidia/platform/t210/common/kernel-dts/t210-common-platforms/tegra210-p2530-common.dtsi 2019-09-18 13:26:22.723470000 +0200

I have tried Jetpack 4.4.1 and also, 4.5.1. For Jetpack 4.5.1, it can detect SD card only by changing max-clk-limit = <0xc28cb00> /* to <0x61a80> */ in the tegra210-p3448-0002-p3449-0000-b00.dtb file. How to SD card speed?

Those source code is in another tarball. You can download it from our download center.

Hi Wayne,
I found it in my host system (use for flashing a Nano). Is it in /home/microcube/Downloads/Linux_for_Tegra/source/public/kernel_src.tbz2. How to update files and flash to a production Nano SOM?


We have the tutorial here.

I have followed the link from #5, I did not find boot/image file in the step 5 of Building the NVIDIA Kernel. Please help?

Do you find Linux_for_Tegra? If so, show me what is inside.

The only Linux_for_Tegra found is after tar from source
tar –xjf kernel_src.tbz2
There is no other Linux_for_Tegra when I search. There are Linux_forTegra/source/public/hardware, …kernel and many .tbz files.

Then you are using the wrong one.

The Linux_for_Tegra should be installed by sdkmanger on your host. The flash process is done by the script inside this package.

Sorry for not explaining clearly. There is an image file in JetPack4.5.1/Linux_for_Tegra/kernel folder. In step 5 of Building the NVIDIA Kernel, it said to replace the image file from $TEGRA_KERNEL_OUT/arch/arm64/boot/Image. I did not see boot folder. So there is no image file to replace with.

During step 4 of Building the NVIDIA Kernel from the link in #5 chat, I saw 2 errors of the same, "unrecognize command line option ‘-mlittle-endian’ message, see attached on line 102 and 109. error during Make ARCH arm64 Out.txt (6.7 KB)

found my error, miss spell CROSS_COMPILE

Now, I cannot find dts inside boot folder from step 6 of Building the NVIDIA Kernel. Please help!!!

Is your biuld process really compiling the dts file? If not, please clean it up and try again.

Sorry, my mistake. I used out image only command.
$ make ARCH=arm64 O=$TEGRA_KERNEL_OUT Image -j8

I have completed the patch and build the kernel per the link. Production SOM did not detect SD card. If modified the max-clk-limit = <400000>, it will detect SD card but the speed is slow. Can you help? Currently, I am deleting nvidia,min-tap-delay from nvidia/soc/t210/kernel-dts/tegra210-soc/tegra210-sdhci.dtsi and rebuilding the kernel. Is there any other to try?
BTW, I uses cross compiling and all modifications are on a host system (non-jetson).

Please share the dmesg and full dts when you hit any problem with kernel issue. And take this as common sense whenever you are bringing up a custom board.

Thank you for your help. Here are dmesg and dtb file from the Nano SOM.
dmesg.txt (127.4 KB)
kernel_tegra210-p3448-0002-p3449-0000-b00.dtb (237.6 KB)

Please convert your dtb back to dts through the dtc tool.