Slow when Initializing 2023.1.0 Isaac Sim in container and having trouble in live stream


I noticed there is a new release of Isaac Sim 2023.1.0 recently and thanks for your work on improving it.

However, I’m transferring some of my work in 2022.2.1 to the latest version and found some problems when I tried to run examples:

  1. Slow initialization time which I believe it’s this warning
    [Warning] [omni.client.python] Detected a blocking function. This will cause hitches or hangs in the UI. Please switch to the async version, which you mentioned installing Nucleus locally would fix the problem, or set an async should work in post here. I wonder how should I fix it if I’m using this OmniIsaacGymEnvs repository.
    Is the connection to the Nucleus necessary if I’m using my own USD files that are stored on the server? I also experienced that warning when running my own examples.

  2. I cannot retrieve visuals by setting enable_livestream=True after create docker container by calling ./docker/ in the OmniIsaacGymEnvs repository with error:
    Unable to initiate a connection to the server. Please validate the server address is accurate, and that it is reachable from the network.

    Failed with Cartpole, Ant, and my own example. I only cloned the repository without changing anything.
    While I run it in the 2022.2.1 container, it works. Attach screenshot.

Since these problems are not fixed, I probably will not transfer my work to the latest version 2023.1.0 just now and I’m looking forward to your reply.


Hi. For #1, the warning comes from the get_assets_root_path() function. You can skip this if you are using direct paths to our files. This function is helpful if you are using the default assets and can change the path using the –/persistent/isaac/asset_root/default flag.

For #2, please try the new example with headless=True enable_livestream=True and see if that works. Are you running both the Isaac Sim app and the Omniverse Streaming Client on the same machine? If you are, try the IP address instead.

For #2, Yes, the command I use is /isaac-sim/ scripts/ task=Ant headless=True enable_livestream with latest streaming client 103.1.1 and training is in remote server instead of my local computer which runs the Omniverse Streaming Client. So, change IP to default is not applicable to me. I tried by cloning the repository again but streaming is not working.

Those are the steps I did:

  1. git clone
  2. ./docker/
  3. /isaac-sim/ scripts/ task=Ant headless=True enable_livestream=True
  4. Connect through Streaming Client and Failed.

As for #1, I look deeper into the code. I have removed the get_assets_root_path() from my own task. However, here is the problem I still need to add the default ground plane by calling scene.add_default_ground_plane(prim_path=self._ground_plane_path) in, line 168, which leads to the Warning and program hanging.

Is downloading the Nuclues server locally the only choice right now? I just tried to use isaac-sim 2023.1.0 connecting to Nuclues 2022.2.1, which still experiences the hanging problem.

Using a Nucleus to access the Isaac Sim assets is recommended.
However, for some use cases, you can try using the downloaded assets pack instead.

Hi there, for the livestream issue, could you try waiting a few minutes until the training iterations start before connecting to the streaming client? The first runs might take some time for the app to load and the streaming client may not be able to pick up the connection during that time.

HI kellyg,

Yes, I did not press the connect button until training was on. I mean after all these fps, the iteration records show up.

It used to work in the 2022.2.1 version.