Solution to /usr/bin/ld: cannot find -lXmu problem Solution to compilation error with -lXmu

Hi,

I got the following make error:-

steve@steve-laptop:~/NVIDIA_CUDA_SDK/projects/fluidsGL$ make
/usr/bin/ld: cannot find -lXmu
collect2: ld returned 1 exit status
make: *** […/…/bin/linux/release/fluidsGL] Error 1
steve@steve-laptop:~/NVIDIA_CUDA_SDK/projects/fluidsGL$

and fixed it by running:-

sudo apt-get install libxmu-dev libxmu6

I read a couple of other posts of this forum about resolving this type of compilation problem and they made me think I had to edit various files and compilation options etc. etc. but then found the above solution on the wider web and it worked for me. This was on xubuntu 8 btw.

Also (in case it help you) had to downgrade from gcc-4.3 to gcc-4.1 and g+±4.3 to g+±4.1 which i did using apt-get remove and apt-get install for each of them, and do

sudo apt-get install freeglut3-dev

to get everything compiling OK.

cheers

steve

BTW - I’m sure most Linuxy people would know to install libxmu, but to us newbies might be helpful to read above O:)

Thank you very much. I appreciated your help.