"SOLVED" Can't seem to get CUDA to work simultaneously with Vulkan (incompatible drivers?)

I have a Windows 10 Pro (Version 1803, OS Build 17134.407) system with two GTX 1080 ti cards.

I had the latest production NVidia drivers installed and successfully installed CUDA (cuda_10.0.130_411.31_win10.exe is the installer). After some pain got samples compiling in VS 2017.

Downloaded the latest VulkanSDK from https://www.lunarg.com/vulkan-sdk/. Found that I could not get any Vulkan code running (incompatible driver errors). I got the same error from the simpleVulkan CUDA sample program.

After much searching I downloaded the Beta Windows driver version 399.41 from NVidia. Now all of my Vulkan code works. However, none of my CUDA code works anymore. All of the CUDA samples produce errors similar to…

[Matrix Multiply Using CUDA] - Starting...
CUDA error at C:\ProgramData\NVIDIA Corporation\CUDA Samples\v10.0\common\inc\helper_cuda.h:708 code=35(cudaErrorInsufficientDriver) "cudaGetDeviceCount(&device_count)"

Any suggestions? What other info can I provide to make this easier to diagnose? I’m new to Windows. I have no problems with my Mac and Linux setups.

“Solved” the problem after a fashion. It required multiple reinstallations of CUDA and the non-Beta driver (416.94). Reinstalling CUDA caused my screens to go black. Had to hard reboot and lost my second screen. After reinstallation of the non-beta driver for Vulkan, everything started working. Since I never saw the CUDA installation complete, not even sure everything is in place. But for now I can code.

I’ve seen lots of other complaints about the “black screen of death” during NVidia driver installs. It has happened to me many times during this process.

Lame.