id titles(e.g Doom, Wolfenstein) not working after installing CUDA 10

After installing CUDA Toolkit 10, Doom and Wolfenstein II will not start, instead throwing the error
“VK_ERROR_INCOMPATIBLE_DRIVER”. I’ve tried installing the toolkit both with and without the bundled graphics driver.

Any ideas? I have not tried other Vulkan games.

Edit: Windows 10 Pro build 1803, GTX 1080TI. Nvidia driver 411.70, and bundled with CUDA setup.

Did you manage to solve this? I guess I can run the game on OpenGL, but I’m not a fan of that solution.

Well, I tried installing CUDA again a couple of weeks ago, and the games worked as they should. I’ve updated the graphics drivers a couple of times since i posted my problem, and I believe that’s what fixed it.

EDIT: Never mind, the problem is still there.

I fixed it by installing the new drivers (the freesync ones). Haven’t yet tested if cuda still works, but I can definitively play Doom.

Reinstalling that version(was already on it) fixed it again. I did reinstall CUDA recently, seems like that broke it. Looks like the solution is to reinstall the graphics drivers after installing/reinstalling CUDA.

BTW, CUDA works as well.

Thanks for your input.