CUDA error

Hello, gents,
Am trying to install a simulator software which need CUDA SDK to be installed in order to run correctly. I installed CUDA SDK 10 and when I pressed “run”, this error message (picture link attached) pops up. laptop properties: Win7 (64-bit), i7.

Link>> https://imgur.com/a/CjwOhOk

Any idea why this error message and how to solve it?

your help will be highly appreciated,
Aows

https://imgur.com/a/CjwOhOk

The insufficient driver message usually means that either:

  1. You do not have a CUDA GPU
  2. Your GPU driver is installed incorrectly
  3. Your installed GPU driver is too old for the CUDA version (10.0) that you installed

Hello, dear Robert,
Thanks for your reply,

My driver is ( NVIDIA GeForce GT 635M),
is it compatible with CUDA 10?

thanks,

GT 635M is a Fermi GPU, although it is CUDA capable, it is not compatible with CUDA 10. The last CUDA version supporting that GPU is CUDA 8

Thanks indeed dear Robert,
Is that mean if I install CUDA 8, this error message will disappear?

I don’t know anything about your application or its behavior. What I can tell you is that CUDA 10 will not work with that GPU. If I wanted to use that GPU for CUDA acceleration, I would install a version of CUDA 8. Everything else is up to you.

I see,
two questions:

  1. I want to completely uninstall the previously installed CUDA 10, is it just from control panel, or there is another method?
  2. What did you meant by “Fermi”?

highly appreciated,

please follow the instructions for uninstall provided in the windows install guide

fermi is just an older GPU generation, you can get more information on it using google search

Thanks dear Robert,

Hello dear, Robert @Robert_Crovella,
I uninstalled CUDA 10, restarted my laptop, installed CUDA 8, and it the beginning of the installation, I got this error, (link below) https://imgur.com/a/eTnQIRJ , any idea what is the solution?

https://imgur.com/a/eTnQIRJ

Might be worth trying an even older CUDA version, like 7 or 7.5 just to see if it works or if the error is more meaningful.

Hello, Asulocpp,
I installed V8 but still error when running the software, any ideas?

Thanks

Did you try 7 or 7.5?

No, not yet, @saulocpp ,

At first, I tried 10 and it didn’t work at all, then i uninstalled it and install 8 and it worked,

do you think 7 is necessary?

Thanks saulocpp

If it worked with 8, then ok.

the software that am working with consists of two processes, first is modeling, second is simulation. Modeling is OK, the problem is that the software produce an error when i press the “Run” (which is part of the simulation process).