CUDA 10.1, Visual Studio 2017 and a GTX 1050 Laptop - Worked but then it stopped.

So I recently got a new Lenovo IdeaPad 330 with a GTX 1050, working and compiling CUDA 10.1 samples in Visual Studio 2017. It worked and I was able to compile and run the CUDA 10.1 demos nicely. I used VS2017 to open and compile the CUDA Smoke Particle demo then ran it to get a reportedly 173.5 fps. It looked smooth enough but that fps looked too high. Anyway after configuring the rest of the new system and a few restarts I loaded VS2017 to test CUDA again. However something had changed in my video configuration as I could no longer use the Nvidia card’s acceleration. Here’s what I did firstly to get the system up and running:

1 Installed Microsoft Visual Studio Community 2017.
2 Installed Nvidia’s CUDA 10.1.105 package.
3 Opened GeForce Experience and installed the GeForce Game Ready Driver 425.31 package.
4 Compiled the CUDA demo in Visual Studio 2017 using (retargeting) Windows SDK Version 10.0.15063.0.

This worked at first but after a couple of restarts the drivers seemed to have rolled back and stopped functioning correctly. Device manager reports everything as fine with the card and VS2017 still compiles CUDA samples but there’s no access to 3D acceleration. Also the Nvidia Control panel fails to load and just closes itself down. The CUDA demos now freeze on the first frame.

Maybe the drivers aren’t stable for the Lenovo implementation of the GTX 1050 but it was working fine earlier. I don’t suppose anyone has come across this or know what can be done.

What is the latest driver offered by Lenovo for your laptop?

You may wish to try that, and simply use whatever CUDA version is compatible with that driver.

Lenovo have provided three video driver installation files on the support website. Two of which are for the Nvidia card while the third is for the Intel 630. The two Nvidia files have versions 417.35 and 417.22 of the drivers as well as the NVIDIA GeForce Experience

After installation of the provided drivers and reboot, device manager says the cards have an error with a message “Windows cannot verify the digital signature for the drivers required for this device…”. Device manager also says that the current driver version is (I think the last 5 digits count so that’s 418.96?). So it’s confusing as to which version is installed.

I tried to open up NVIDIA Control Panel but that did not work. So I tried the GeForce Experience and saw that it had immediately began downloading the Game Ready Drivers version 425.31. Since that’s how it worked last time I clicked through to install the driver. After the reboot, nothing seemed to have changed and device manager says the device is working when not even the NVIDIA Control Panel loads up.

It seems like the only way to restore the driver functionality is to complete reset my Windows installation. This takes too much time considering that it was working just fine not that long ago. I don’t know if there was a driver conflict or inference from the other applications I have installed. But I’d prefer to keep them rather than constantly having to reset the whole Windows installation every time the NVIDIA drivers decided to stop working.

I should have known better to check it first but the problem was caused by my installation of Duet Display v1.5.6.7 by Kairos. After removing the software everything appears to be working correctly again! If anyone else (probably no one) runs into this problem try uninstalling Duet Display or other screen sharing applications like HP RGS.