Can't install Cuda...

Not sure where to start but think I’ll start with my first problem with the Nvidia drivers.
When the drivers 397.31 rolled out, during the installation I got a windows message saying something like “windows is forced to reinstall display drivers”. Then when Nvidia was done my resolution was all f-ked and only one of my screens was working, even tho I hade the drivers installed in control panel just couldn’t open nor use them.
I tried things like a fresh driver reinstall in safe mode, same thing happened. Anyways, I went back to the version 391.35 which works just fine.

Now I’m trying to get Cuda 8.0, I have visual studio 2015, I have disabled windows updates (in case that is the problem). However it always ends with “installation failed” I tried uncheck the “integrate with visual studio” because that is the one that says “failed” if I have it selected. However, when I do not install it, during the installation of Cuda ALL of my screens go black, all of them but one gets “no signal” however the one who dosen’t still has nothing on it but black. No mouse, no start menu.
I have also tried to only install cuda, or the hole package with the drivers and stuff.
Not sure where or how I can supply an error log or where I can find it on my computer?

I’m so pissed now and have been trying to fix this for like 2 days. I’m soon out of patient and thinking about reformatting my computer and hope that helps, however that would just as a big pain in the ass to get all the programs installed again…

I got windows 10 64 bit.

Never mind!
Solved it by just installing one part of a time. Even thought it was frustrating…