corrupted installation?

tried to reinstall CUDA 8.0 Development Kit after installing vs2017. but then found out it was not supported…:(

removed 8, installed 9.

  1. previous 8.0 project was not upgraded. forced it to load by changing vcproj file but it says CUDA 9.0 directories are missing.
  2. created new 9.0 project in vs2017.
    “The CUDA Toolkit v9.0 directory ‘’ does not exist. Please verify the CUDA Toolkit is installed properly or define the CudaToolkitDir property to resolve this error”
  3. vs2015 hangs on launch until I uninstall 9.0

every time I do this it seems to go OK until the development kit tries to install a video driver. why is it doing that? I already have a supported video driver installed. how do I make it stop?

how do I get a good install? if not, how do I know what went wrong?

When you install CUDA, the installer should offer an opportunity to skip the installation of the graphics drivers. You may need to switch from “default install” to “custom install” to see it (sorry, it has been a few months since I last installed CUDA, I don’t recall the details).

Why does the default CUDA installation include installation of a compatible graphics driver? Because when the CUDA installer did not do that, in the early days of CUDA, there were many more people who wound up with a non-functional CUDA installation because of a mismatching graphics driver (the CUDA driver relies on low-level functionality provided in the graphics driver, e.g. GPU memory management). After switching to the current model where a matching graphics driver is installed along with CUDA, the number of people with installation problems decreased significantly.

thanks. just found that. don’t know how I missed it the first few times…

but, the installation definitely failed to properly setup vs2015 and vs2017.
how do I find out what went wrong?

If by “properly setup vs2015 and vs2017” you mean the integration into the MSVS IDE, I do not know anything about it because I use command line tools exclusively, never the IDE.

the installer creates logs

https://devtalk.nvidia.com/default/topic/1024655/cuda-setup-and-installation/cuda-9-0-176-installer-fails-every-time/post/5212701/#5212701

apparently the driver installation failed. tried to install the latest driver and that failed. left my display without a driver. tried to restore through device manager but that failed too…:(

running again with a log. never had a problem with this machine before.
why would the driver install fail?
do I need to uninstall vs2017 first?

ran setup as follows

setup.exe -log:“c:\user<first.last>\downloads\388.43-desktop-win8-win7-64bit-international-whql\setup.log” -loglevel:6

driver install failed.
no setup.log was created that I can find

now what do we do?

  • used 3dguru display driver uninstaller in safe mode.
  • ran installation of just the graphics driver in safe mode
  • now it’s back

go figure.

thanks for listening!