CUDA 5.5 Install Failed: Required Files Not Found

Hi all,

I have CUDA 5.0 and need to upgrade to CUDA 5.5. When I run the CUDA 5.5 Installer (default settings), it fails during installation of the CUDA Toolkit, and displays a dialog box with the following message:

“NVIDIA Installer Failed.”

If I close the installer and try again, I get a different error:

“NVIDIA Installer Cannot Continue: Required Files Are Missing.”

If I reboot and try again, I get the first message once again.

Is there a driver for 5.0 I need to uninstall for 5.5 to install? Any help is appreciated.

I’m using Windows 7 64-bit.

Hi ecarney1,
A couple of things may be going on here.

First, there’s an issue where if you run the install again too soon after the first invocation of the installer, you’ll run into “Required Files Are Missing”. It’s best to wait ~5 min between installer invocations to prevent this.

Second, let’s get some logs. Please extract the installer using any LZMA compression utility (like 7zip) to a folder of your choice. And then within a cmd prompt, run:
setup.exe -log:“C:\path\that\exists” -loglevel:6

Then attach the *.log files that are generated in C:\path\that\exists


Hi Andy,
I’ve been trying everything I can think of to get this to work. I uninstalled CUDA 5.0, uninstalled every driver, downloaded and installed the latest driver for my card (Tesla K20)… all to no avail. The CUDA 5.5 installer still fails.

I ran through your procedure. The log files are attached.

Thanks for the help!

LOG.RunDll32.EXE.log (53.3 KB)

Hi ecarney1,
Was there a log called LOG.setup.exe.log? If so, please also attach that one.

Sorry, here’s LOG.setup.exe.log
LOG.setup.exe.log (6.88 MB)

Edit: Here’s the relevant parts that it errored on:

Sounds like it’s looking for some files that are part of the VS2008 compiler, but failing. Perhaps try uninstall/reinstall the VS2008 Professional compiler and update to its latest service pack.

Thanks, @vacaloca! The reason for all this is that I’m upgrading from Visual Studio 2010 Express to Visual Studio 2012 Professional (to use NSight). So I need CUDA 5.5 rather than CUDA 5.0. Do you think I should install Visual Studio 2012 Pro first, and then CUDA 5.5, and that it might work then?

Thanks again!

Okay, got it, yes. Uninstall VS Express and any other existing VS versions from Programs/Features, install VS2012 Professional, update it with the Service Pack and then install CUDA 5.5 toolkit. It should install fine then.

Uninstalled older VS versions, installed VS 2012 Pro, and then installed CUDA 5.5… works great!

Any ideas on the best way to get intellisense working…?

Never mind on the intellisense question - got it working.

how did you get intellisense working?