NVIDIA Installer failed, windows 10, cuda 10.0

I managed to install this on another system (windows 10 1809) without much trouble after reading https://docs.nvidia.com/cuda/archive/10.0/cuda-installation-guide-microsoft-windows/index.html for the right visual studio version.

I have been trying to get this installed for about a day now on windows 10 1703.

windows 10 1703 (can’t upgrade because headless doesn’t work properly for me on newer windows)
video driver 441.20
Visual Studio Community 2015
headless machine with 4x GTX 1060(working correctly and listed on nvidia-smi) and integrated intel graphics
cuda 10.0 (only installing the CUDA component)

I already tried uninstalling everything, restarting and reinstalling again, nothing seems to work, I just get the “NVIDIA Installer failed”.

Visual studio seems to be detected as I don’t get a warning about that before the installation begins.
I will need it but tried to install with “visual studio integration” unchecked, it failed in the same way.

I was so excited to start working with this setup :/, any advice/guide would be much appreciated.

1 Like

Fixed, I’m not sure what really solved it but I had a “c:\program files\nvidia gpu computing toolkit” folder, after I removed it and tried to install again the cuda installer worked. I also used DDU during the whole ordeal.